summaryrefslogtreecommitdiffstats
path: root/smartproxy/configure.ac
diff options
context:
space:
mode:
authorRob Crittenden <rcritten@redhat.com>2013-12-03 09:14:00 -0700
committerRob Crittenden <rcritten@redhat.com>2014-02-27 15:50:37 -0500
commit4facb9d8ceea6ffe07297f375bf05d9c72bc6125 (patch)
tree44bd9f9645f87dccd84da37ccae0e2c109cd64c3 /smartproxy/configure.ac
parentadcd373931c50d91550f6b74b191d08ecce5b137 (diff)
downloadfreeipa.git-master.tar.gz
freeipa.git-master.tar.xz
freeipa.git-master.zip
Implement an IPA Foreman smartproxy serverHEADmaster
This currently server supports only host and hostgroup commands for retrieving, adding and deleting entries. The incoming requests are completely unauthenticated and by default requests must be local. Utilize GSS-Proxy to manage the TGT. Configuration information is in the ipa-smartproxy man page. Design: http://www.freeipa.org/page/V3/Smart_Proxy
Diffstat (limited to 'smartproxy/configure.ac')
-rw-r--r--smartproxy/configure.ac75
1 files changed, 75 insertions, 0 deletions
diff --git a/smartproxy/configure.ac b/smartproxy/configure.ac
new file mode 100644
index 00000000..5908a7f1
--- /dev/null
+++ b/smartproxy/configure.ac
@@ -0,0 +1,75 @@
+AC_PREREQ(2.59)
+m4_include(../version.m4)
+AC_INIT([ipa-server],
+ IPA_VERSION,
+ [https://hosted.fedoraproject.org/projects/freeipa/newticket])
+
+AM_INIT_AUTOMAKE([foreign])
+
+AM_MAINTAINER_MODE
+
+AC_SUBST(VERSION)
+AC_SUBST([INSTALL_DATA], ['$(INSTALL) -m 644 -p'])
+
+AC_PROG_MKDIR_P
+AC_PROG_AWK
+AC_PROG_SED
+
+AC_PATH_PROG(XGETTEXT, xgettext, [no])
+if test "x$XGETTEXT" = "xno"; then
+ AC_MSG_ERROR([xgettext not found, install gettext])
+fi
+
+AC_PATH_PROG(MSGFMT, msgfmt, [no])
+if test "x$MSGFMT" = "xno"; then
+ AC_MSG_ERROR([msgfmt not found, install gettext])
+fi
+
+AC_PATH_PROG(MSGINIT, msginit, [no])
+if test "x$MSGINIT" = "xno"; then
+ AC_MSG_ERROR([msginit not found, install gettext])
+fi
+
+AC_PATH_PROG(MSGMERGE, msgmerge, [no])
+if test "x$MSGMERGE" = "xno"; then
+ AC_MSG_ERROR([msgmerge not found, install gettext])
+fi
+
+AC_PATH_PROG(MSGCMP, msgcmp, [no])
+if test "x$MSGCMP" = "xno"; then
+ AC_MSG_ERROR([msgcmp not found, install gettext])
+fi
+
+AC_PATH_PROG(MSGATTRIB, msgattrib, [no])
+if test "x$MSGATTRIB" = "xno"; then
+ AC_MSG_ERROR([msgattrib not found, install gettext])
+fi
+
+AC_PATH_PROG(TX, tx, [/usr/bin/tx])
+
+AC_ARG_WITH([gettext_domain],
+ [AS_HELP_STRING([--with-gettext-domain=name],
+ [set the name of the i18n message catalog])],
+ [],
+ [with_gettext_domain=ipa])
+AC_SUBST(GETTEXT_DOMAIN, $with_gettext_domain)
+
+dnl ---------------------------------------------------------------------------
+dnl - Set the data install directory since we don't use pkgdatadir
+dnl ---------------------------------------------------------------------------
+
+IPA_DATA_DIR="$datadir/ipa"
+IPA_SYSCONF_DIR="$sysconfdir/ipa"
+LOGROTATE_DIR="$sysconfdir/logrotate.d"
+AC_SUBST(IPA_DATA_DIR)
+AC_SUBST(IPA_SYSCONF_DIR)
+AC_SUBST(LOGROTATE_DIR)
+
+# Files
+
+AC_CONFIG_FILES([
+ Makefile
+ man/Makefile
+])
+
+AC_OUTPUT