summaryrefslogtreecommitdiffstats
path: root/daemons/ipa-slapi-plugins/ipa-pwd-extop/Makefile.am
diff options
context:
space:
mode:
authorNathaniel McCallum <npmccallum@redhat.com>2014-01-28 17:09:58 -0500
committerPetr Viktorin <pviktori@redhat.com>2014-02-21 10:26:02 +0100
commita51b07c27566ecf059cca96551028d8cbe5078d3 (patch)
tree3ddbe0e7e0544becd080878e0eea68d1cc1b4286 /daemons/ipa-slapi-plugins/ipa-pwd-extop/Makefile.am
parent49038cda9fcddf75e04d1e36df3707432b96fb6d (diff)
downloadfreeipa.git-a51b07c27566ecf059cca96551028d8cbe5078d3.tar.gz
freeipa.git-a51b07c27566ecf059cca96551028d8cbe5078d3.tar.xz
freeipa.git-a51b07c27566ecf059cca96551028d8cbe5078d3.zip
Add OTP sync support to ipa-pwd-extop
Reviewed-By: Alexander Bokovoy <abokovoy@redhat.com>
Diffstat (limited to 'daemons/ipa-slapi-plugins/ipa-pwd-extop/Makefile.am')
-rw-r--r--daemons/ipa-slapi-plugins/ipa-pwd-extop/Makefile.am13
1 files changed, 3 insertions, 10 deletions
diff --git a/daemons/ipa-slapi-plugins/ipa-pwd-extop/Makefile.am b/daemons/ipa-slapi-plugins/ipa-pwd-extop/Makefile.am
index 03e36a21..b8d98785 100644
--- a/daemons/ipa-slapi-plugins/ipa-pwd-extop/Makefile.am
+++ b/daemons/ipa-slapi-plugins/ipa-pwd-extop/Makefile.am
@@ -10,6 +10,7 @@ KRB5_UTIL_SRCS = $(KRB5_UTIL_DIR)/ipa_krb5.c \
AM_CPPFLAGS = \
-I. \
-I$(srcdir) \
+ -I$(srcdir)/../libotp \
-I$(PLUGIN_COMMON_DIR) \
-I$(KRB5_UTIL_DIR) \
-I$(COMMON_BER_DIR) \
@@ -34,24 +35,16 @@ AM_LDFLAGS = \
-avoid-version \
-export-symbols-regex ^ipapwd_init$
-# OTP Convenience Library and Tests
-noinst_LTLIBRARIES = libotp.la
-libotp_la_SOURCES = otp.c
-check_PROGRAMS = t_hotp t_totp
-t_hotp_LDADD = libotp.la
-t_totp_LDADD = libotp.la
-TESTS = $(check_PROGRAMS)
-
# Plugin Binary
plugindir = $(libdir)/dirsrv/plugins
plugin_LTLIBRARIES = libipa_pwd_extop.la
-libipa_pwd_extop_la_LIBADD = libotp.la
+libipa_pwd_extop_la_LIBADD = $(builddir)/../libotp/libotp.la
libipa_pwd_extop_la_SOURCES = \
- auth.c \
common.c \
encoding.c \
prepost.c \
ipa_pwd_extop.c \
+ syncreq.c \
$(KRB5_UTIL_SRCS) \
$(NULL)