summaryrefslogtreecommitdiffstats
path: root/daemons/ipa-slapi-plugins/ipa-pwd-extop/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2010-11-04 19:29:01 +0100
committerSimo Sorce <ssorce@redhat.com>2010-11-22 16:01:35 -0500
commit3b7a86024b53fd0ac1a98e92bd93a170a1979aec (patch)
treec3fb64a3896c46f6822ac63d786320c0f7ec2e9b /daemons/ipa-slapi-plugins/ipa-pwd-extop/Makefile.am
parentce75d1c6d6595bcb26dbacf7393098a8f9accb3f (diff)
downloadfreeipa.git-3b7a86024b53fd0ac1a98e92bd93a170a1979aec.tar.gz
freeipa.git-3b7a86024b53fd0ac1a98e92bd93a170a1979aec.tar.xz
freeipa.git-3b7a86024b53fd0ac1a98e92bd93a170a1979aec.zip
Use internal implementation of internal Kerberos functions
Don't use KRB5_PRIVATE. The patch implements and uses the following krb5 functions that are otherwise private in recent MIT Kerberos releases: * krb5_principal2salt_norealm * krb5_free_ktypes Signed-off-by: Simo Sorce <ssorce@redhat.com>
Diffstat (limited to 'daemons/ipa-slapi-plugins/ipa-pwd-extop/Makefile.am')
-rw-r--r--daemons/ipa-slapi-plugins/ipa-pwd-extop/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/daemons/ipa-slapi-plugins/ipa-pwd-extop/Makefile.am b/daemons/ipa-slapi-plugins/ipa-pwd-extop/Makefile.am
index 6f6092d2..41d9f237 100644
--- a/daemons/ipa-slapi-plugins/ipa-pwd-extop/Makefile.am
+++ b/daemons/ipa-slapi-plugins/ipa-pwd-extop/Makefile.am
@@ -1,11 +1,14 @@
NULL =
PLUGIN_COMMON_DIR=../common
+KRB5_UTIL_DIR= ../../../util
+KRB5_UTIL_SRCS=$(KRB5_UTIL_DIR)/ipa_krb5.c
INCLUDES = \
-I. \
-I$(srcdir) \
-I$(PLUGIN_COMMON_DIR) \
+ -I$(KRB5_UTIL_DIR) \
-DPREFIX=\""$(prefix)"\" \
-DBINDIR=\""$(bindir)"\" \
-DLIBDIR=\""$(libdir)"\" \
@@ -28,6 +31,7 @@ libipa_pwd_extop_la_SOURCES = \
ipapwd_encoding.c \
ipapwd_prepost.c \
ipa_pwd_extop.c \
+ $(KRB5_UTIL_SRCS) \
$(NULL)
libipa_pwd_extop_la_LDFLAGS = -avoid-version