summaryrefslogtreecommitdiffstats
path: root/daemons/ipa-otpd/Makefile.am
diff options
context:
space:
mode:
authorNathaniel McCallum <npmccallum@redhat.com>2013-04-11 14:03:25 -0400
committerMartin Kosek <mkosek@redhat.com>2013-05-17 09:30:51 +0200
commit203754691c28243dd3cf378e98390fc0a455b485 (patch)
treef1574334a744f2b2b54c90a0eec08a985151447b /daemons/ipa-otpd/Makefile.am
parent5d51ae50a59466fa2d6d230d7f2879de34210f0c (diff)
downloadfreeipa.git-203754691c28243dd3cf378e98390fc0a455b485.tar.gz
freeipa.git-203754691c28243dd3cf378e98390fc0a455b485.tar.xz
freeipa.git-203754691c28243dd3cf378e98390fc0a455b485.zip
Add the krb5/FreeIPA RADIUS companion daemon
This daemon listens for RADIUS packets on a well known UNIX domain socket. When a packet is received, it queries LDAP to see if the user is configured for RADIUS authentication. If so, then the packet is forwarded to the 3rd party RADIUS server. Otherwise, a bind is attempted against the LDAP server. https://fedorahosted.org/freeipa/ticket/3366 http://freeipa.org/page/V3/OTP
Diffstat (limited to 'daemons/ipa-otpd/Makefile.am')
-rw-r--r--daemons/ipa-otpd/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/daemons/ipa-otpd/Makefile.am b/daemons/ipa-otpd/Makefile.am
new file mode 100644
index 00000000..ed99c3ec
--- /dev/null
+++ b/daemons/ipa-otpd/Makefile.am
@@ -0,0 +1,21 @@
+AM_CFLAGS := $(CFLAGS) @LDAP_CFLAGS@ @LIBVERTO_CFLAGS@
+AM_LDFLAGS := $(LDFLAGS) @LDAP_LIBS@ @LIBVERTO_LIBS@ @KRAD_LIBS@
+
+noinst_HEADERS = internal.h
+libexec_PROGRAMS = ipa-otpd
+dist_noinst_DATA = ipa-otpd.socket.in ipa-otpd@.service.in test.py
+systemdsystemunit_DATA = ipa-otpd.socket ipa-otpd@.service
+
+ipa_otpd_SOURCES = bind.c forward.c main.c parse.c query.c queue.c stdio.c
+
+%.socket: %.socket.in
+ @sed -e 's|@krb5kdcdir[@]|$(krb5kdcdir)|g' \
+ -e 's|@UNLINK[@]|@UNLINK@|g' \
+ $< > $@
+
+%.service: %.service.in
+ @sed -e 's|@libexecdir[@]|$(libexecdir)|g' \
+ -e 's|@sysconfdir[@]|$(sysconfdir)|g' \
+ $< > $@
+
+CLEANFILES = $(systemdsystemunit_DATA)