summaryrefslogtreecommitdiffstats
path: root/tests/include/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/include/Makefile.am')
-rw-r--r--tests/include/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/tests/include/Makefile.am b/tests/include/Makefile.am
new file mode 100644
index 0000000..7174bec
--- /dev/null
+++ b/tests/include/Makefile.am
@@ -0,0 +1,31 @@
+## Makefile.am -- Process this file with automake to produce Makefile.in
+## Copyright (C) 2007 Peng Wu
+##
+## This program is free software; you can redistribute it and/or modify
+## it under the terms of the GNU General Public License as published by
+## the Free Software Foundation; either version 2, or (at your option)
+## any later version.
+##
+## This program is distributed in the hope that it will be useful,
+## but WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+## GNU General Public License for more details.
+##
+## You should have received a copy of the GNU General Public License
+## along with this program; if not, write to the Free Software
+## Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
+
+INCLUDES = -I$(top_srcdir)/src \
+ -I$(top_srcdir)/src/include \
+ -I$(top_srcdir)/src/storage \
+ -I$(top_srcdir)/src/lookup \
+ @GLIB2_CFLAGS@
+
+TESTS = test_memory_chunk
+
+noinst_PROGRAMS = test_memory_chunk
+
+test_memory_chunk_SOURCES = test_memory_chunk.cpp
+
+test_memory_chunk_LDADD = @GLIB2_LIBS@
+