summaryrefslogtreecommitdiffstats
path: root/src/storage/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/storage/CMakeLists.txt')
-rw-r--r--src/storage/CMakeLists.txt38
1 files changed, 0 insertions, 38 deletions
diff --git a/src/storage/CMakeLists.txt b/src/storage/CMakeLists.txt
deleted file mode 100644
index e33e213..0000000
--- a/src/storage/CMakeLists.txt
+++ /dev/null
@@ -1,38 +0,0 @@
-set(
- CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIC"
-)
-
-set(
- LIBSTORAGE_HEADERS
- chewing_key.h
- pinyin_custom2.h
-)
-
-set(
- LIBSTORAGE_SOURCES
- phrase_index.cpp
- phrase_large_table2.cpp
- ngram.cpp
- tag_utility.cpp
- pinyin_parser2.cpp
- chewing_large_table.cpp
-)
-
-add_library(
- storage
- STATIC
- ${LIBSTORAGE_SOURCES}
-)
-
-target_link_libraries(
- storage
- ${GLIB2_LIBRARIES}
- ${BERKELEY_DB_LIBRARIES}
-)
-
-install(
- FILES
- ${LIBSTORAGE_HEADERS}
- DESTINATION
- ${DIR_INCLUDE_LIBPINYIN}
-)