summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt50
1 files changed, 50 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..4e0b09f
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,50 @@
+set(
+ LIBPINYIN_HEADERS
+ pinyin.h
+)
+
+set(
+ LIBPINYIN_SOURCES
+ pinyin.cpp
+)
+
+add_library(
+ libpinyin
+ SHARED
+ ${LIBPINYIN_SOURCES}
+)
+
+target_link_libraries(
+ libpinyin
+ storage
+ lookup
+)
+
+set_target_properties(
+ libpinyin
+ PROPERTIES
+ OUTPUT_NAME
+ pinyin
+ VERSION
+ 0.0.0
+ SOVERSION
+ 0
+)
+
+install(
+ TARGETS
+ libpinyin
+ LIBRARY DESTINATION
+ ${DIR_LIBRARY}
+)
+
+install(
+ FILES
+ ${LIBPINYIN_HEADERS}
+ DESTINATION
+ ${DIR_INCLUDE_LIBPINYIN}
+)
+
+add_subdirectory(include)
+add_subdirectory(storage)
+add_subdirectory(lookup)