summaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorPeng Wu <alexepico@gmail.com>2013-07-22 11:37:11 +0800
committerPeng Wu <alexepico@gmail.com>2013-07-22 11:37:11 +0800
commitb78429d78df745dd327b6dada6b9bd71ea5df84e (patch)
tree82c4625db8674c66d69fd566fce8efc347e3cb3a /tests/CMakeLists.txt
downloadlibzhuyin-b78429d78df745dd327b6dada6b9bd71ea5df84e.tar.gz
libzhuyin-b78429d78df745dd327b6dada6b9bd71ea5df84e.tar.xz
libzhuyin-b78429d78df745dd327b6dada6b9bd71ea5df84e.zip
import libpinyin code
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt33
1 files changed, 33 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
new file mode 100644
index 0000000..5783407
--- /dev/null
+++ b/tests/CMakeLists.txt
@@ -0,0 +1,33 @@
+add_subdirectory(include)
+add_subdirectory(storage)
+add_subdirectory(lookup)
+
+add_executable(
+ test_pinyin
+ test_pinyin.cpp
+)
+
+target_link_libraries(
+ test_pinyin
+ libpinyin
+)
+
+add_executable(
+ test_phrase
+ test_phrase.cpp
+)
+
+target_link_libraries(
+ test_phrase
+ libpinyin
+)
+
+add_executable(
+ test_chewing
+ test_chewing.cpp
+)
+
+target_link_libraries(
+ test_chewing
+ libpinyin
+)