summaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt32
1 files changed, 31 insertions, 1 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 258afca..5783407 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -1,3 +1,33 @@
add_subdirectory(include)
add_subdirectory(storage)
-add_subdirectory(lookup) \ No newline at end of file
+add_subdirectory(lookup)
+
+add_executable(
+ test_pinyin
+ test_pinyin.cpp
+)
+
+target_link_libraries(
+ test_pinyin
+ libpinyin
+)
+
+add_executable(
+ test_phrase
+ test_phrase.cpp
+)
+
+target_link_libraries(
+ test_phrase
+ libpinyin
+)
+
+add_executable(
+ test_chewing
+ test_chewing.cpp
+)
+
+target_link_libraries(
+ test_chewing
+ libpinyin
+)