summaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorJim Huang <jserv@0xlab.org>2011-11-03 05:27:00 +0800
committerPeng Wu <alexepico@gmail.com>2011-11-03 11:08:20 +0800
commit146d3c7185b6beafac1f1f818e638f32f2b9b743 (patch)
treeb8e9895a681697bc5ce7b333da96c5adb3d5579c /tests/CMakeLists.txt
parenta041ca72f4b8f971f357acb5f2ccd563a5a7fe46 (diff)
downloadlibpinyin-146d3c7185b6beafac1f1f818e638f32f2b9b743.tar.gz
libpinyin-146d3c7185b6beafac1f1f818e638f32f2b9b743.tar.xz
libpinyin-146d3c7185b6beafac1f1f818e638f32f2b9b743.zip
update CMake rules to reflect recent changes
Signed-off-by: Peng Wu <alexepico@gmail.com>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt32
1 files changed, 31 insertions, 1 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 258afca..5783407 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -1,3 +1,33 @@
add_subdirectory(include)
add_subdirectory(storage)
-add_subdirectory(lookup) \ No newline at end of file
+add_subdirectory(lookup)
+
+add_executable(
+ test_pinyin
+ test_pinyin.cpp
+)
+
+target_link_libraries(
+ test_pinyin
+ libpinyin
+)
+
+add_executable(
+ test_phrase
+ test_phrase.cpp
+)
+
+target_link_libraries(
+ test_phrase
+ libpinyin
+)
+
+add_executable(
+ test_chewing
+ test_chewing.cpp
+)
+
+target_link_libraries(
+ test_chewing
+ libpinyin
+)