summaryrefslogtreecommitdiffstats
path: root/src/lookup/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/lookup/Makefile.am')
-rw-r--r--src/lookup/Makefile.am34
1 files changed, 15 insertions, 19 deletions
diff --git a/src/lookup/Makefile.am b/src/lookup/Makefile.am
index 55c1881..75a7ae5 100644
--- a/src/lookup/Makefile.am
+++ b/src/lookup/Makefile.am
@@ -14,27 +14,23 @@
## You should have received a copy of the GNU General Public License
## along with this program. If not, see <http://www.gnu.org/licenses/>.
-MAINTAINERCLEANFILES = Makefile.in
+MAINTAINERCLEANFILES = Makefile.in
-INCLUDES = -I$(top_srcdir)/src/include \
- -I$(top_srcdir)/src/storage \
- @GLIB2_CFLAGS@
+AM_CPPFLAGS = -I$(top_srcdir)/src/include \
+ -I$(top_srcdir)/src/storage \
+ @GLIB2_CFLAGS@
-noinst_HEADERS = lookup.h \
- pinyin_lookup2.h \
- phrase_lookup.h \
- phonetic_lookup.h \
- phonetic_lookup_linear.h \
- phonetic_lookup_heap.h
+noinst_HEADERS = lookup.h \
+ pinyin_lookup2.h \
+ phrase_lookup.h \
+ phonetic_lookup.h \
+ phonetic_lookup_linear.h \
+ phonetic_lookup_heap.h
-noinst_LTLIBRARIES = liblookup.la
+noinst_LIBRARIES = liblookup.a
-liblookup_la_CXXFLAGS = "-fPIC"
-
-liblookup_la_LDFLAGS = -static
-
-liblookup_la_SOURCES = pinyin_lookup2.cpp \
- phrase_lookup.cpp \
- lookup.cpp \
- phonetic_lookup.cpp
+liblookup_a_SOURCES = pinyin_lookup2.cpp \
+ phrase_lookup.cpp \
+ lookup.cpp \
+ phonetic_lookup.cpp