summaryrefslogtreecommitdiffstats
path: root/src/storage/CMakeLists.txt
diff options
context:
space:
mode:
authorBYVoid <byvoid.kcp@gmail.com>2011-08-11 18:19:08 +0800
committerPeng Wu <alexepico@gmail.com>2011-08-12 10:39:03 +0800
commitc47a095c10f6104fefb7d0406b7f4076ed47f16c (patch)
treea4c3261f5e406b5b6c60f4636f327db9d668bedc /src/storage/CMakeLists.txt
parentbd70f3fe77a2eda3b902c1514b07fbc821c9c1b4 (diff)
downloadlibpinyin-c47a095c10f6104fefb7d0406b7f4076ed47f16c.tar.gz
libpinyin-c47a095c10f6104fefb7d0406b7f4076ed47f16c.tar.xz
libpinyin-c47a095c10f6104fefb7d0406b7f4076ed47f16c.zip
Add cmake scripts.
Diffstat (limited to 'src/storage/CMakeLists.txt')
-rw-r--r--src/storage/CMakeLists.txt42
1 files changed, 42 insertions, 0 deletions
diff --git a/src/storage/CMakeLists.txt b/src/storage/CMakeLists.txt
new file mode 100644
index 0000000..55601b5
--- /dev/null
+++ b/src/storage/CMakeLists.txt
@@ -0,0 +1,42 @@
+set(
+ LIBSTORAGE_HEADERS
+ pinyin_large_table.h
+ pinyin_base.h
+ pinyin_phrase.h
+ phrase_index.h
+ phrase_index_logger.h
+ pinyin_zhuyin_map_data.h
+ phrase_large_table.h
+ ngram.h
+ flexible_ngram.h
+ tag_utility.h
+)
+
+set(
+ LIBSTORAGE_SOURCES
+ pinyin_base.cpp
+ pinyin_large_table.cpp
+ phrase_index.cpp
+ phrase_large_table.cpp
+ ngram.cpp
+ tag_utility.cpp
+)
+
+add_library(
+ libstorage
+ STATIC
+ ${LIBSTORAGE_SOURCES}
+)
+
+target_link_libraries(
+ libstorage
+ ${GLIB2_LIBRARIES}
+ ${BERKELEY_DB_LIBRARIES}
+)
+
+install(
+ FILES
+ ${LIBSTORAGE_HEADERS}
+ DESTINATION
+ ${DIR_INCLUDE_LIBPINYIN}
+)