summaryrefslogtreecommitdiffstats
path: root/src/storage/CMakeLists.txt
diff options
context:
space:
mode:
authorJim Huang <jserv@0xlab.org>2011-11-05 02:24:39 +0800
committerPeng Wu <alexepico@gmail.com>2011-11-07 11:22:41 +0800
commita6af8ae0d842ae50b3e824a76c03ff0f9029f7b1 (patch)
tree1433267369a0c2cdee15ee31e11eb5fc88bea94f /src/storage/CMakeLists.txt
parente7087ceb62f26c74460519ff7afd60fb9c7300b9 (diff)
downloadlibpinyin-a6af8ae0d842ae50b3e824a76c03ff0f9029f7b1.tar.gz
libpinyin-a6af8ae0d842ae50b3e824a76c03ff0f9029f7b1.tar.xz
libpinyin-a6af8ae0d842ae50b3e824a76c03ff0f9029f7b1.zip
CMake: add -fPIC flag to combine static libraries to dynamic one
Machines running Linux on architectures such as amd64 require flag "-fPIC" to be specified to compile shared libraries, and it would be helpful to have this a default for CMake when building libpinyin.
Diffstat (limited to 'src/storage/CMakeLists.txt')
-rw-r--r--src/storage/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/storage/CMakeLists.txt b/src/storage/CMakeLists.txt
index b775350..59f6bfd 100644
--- a/src/storage/CMakeLists.txt
+++ b/src/storage/CMakeLists.txt
@@ -1,4 +1,8 @@
set(
+ CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIC"
+)
+
+set(
LIBSTORAGE_HEADERS
pinyin_large_table.h
pinyin_base.h