summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPeng Wu <alexepico@gmail.com>2014-01-26 14:40:08 +0800
committerPeng Wu <alexepico@gmail.com>2014-01-26 14:40:08 +0800
commit706a20d35cd62358a835f8674a8ec26cde853ff5 (patch)
treeb88db38816a57b31e3498cd868b110a0fd1e4d0f /Makefile.am
parentb193d635b23aaf6fdc0ce552b518d5e7082f7501 (diff)
downloadibus-libzhuyin-706a20d35cd62358a835f8674a8ec26cde853ff5.tar.gz
ibus-libzhuyin-706a20d35cd62358a835f8674a8ec26cde853ff5.tar.xz
ibus-libzhuyin-706a20d35cd62358a835f8674a8ec26cde853ff5.zip
fixes automake
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am34
1 files changed, 30 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index bcec3a8..fe6169a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,22 @@
-## Process this file with automake to produce Makefile.in
-## Created by Anjuta
+# vim:set noet ts=4:
+#
+# ibus-libzhuyin - New Zhuyin engine based on libzhuyin for IBus
+#
+# Copyright (c) 2014 Peng Wu <alexepico@gmail.com>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2, or (at your option)
+# any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
SUBDIRS = po src setup
@@ -11,10 +28,19 @@ dist_doc_DATA = \
INSTALL \
NEWS
-
+ACLOCAL_AMFLAGS = -I m4
# Remove doc directory on uninstall
uninstall-local:
-rm -r $(docdir)
-EXTRA_DIST = config.rpath
+EXTRA_DIST = \
+ autogen.sh \
+ $(NULL)
+
+noinst_DIST = \
+ $(NULL)
+
+DISTCLEANFILES = \
+ po/stamp-it \
+ $(NULL)