summaryrefslogtreecommitdiffstats
path: root/data/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index cfd96ab..5572be2 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -26,6 +26,8 @@ STROKES = strokes
STROKES_AWK = strokes.awk
STROKES_DB = strokes.db
+APPDATA_XML = libpinyin.appdata.xml
+
SUBDIRS = \
icons \
$(NULL)
@@ -48,6 +50,10 @@ $(STROKES_DB): $(STROKES) $(STROKES_AWK)
$(AWK) -f $(srcdir)/$(STROKES_AWK) $(srcdir)/$(STROKES) | @SQLITE3@ $@ || \
( $(RM) $@ ; exit 1 )
+appdatadir = @datadir@/appdata
+
+appdata_DATA = $(APPDATA_XML)
+
desktop_in_in_files = \
ibus-setup-libbopomofo.desktop.in.in \
ibus-setup-libpinyin.desktop.in.in \
@@ -72,6 +78,7 @@ EXTRA_DIST = \
$(ENGLISH_AWK) \
$(STROKES) \
$(STROKES_AWK) \
+ $(APPDATA_XML)
$(NULL)
CLEANFILES = \