summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPeng Huang <shawn.p.huang@gmail.com>2010-08-13 16:20:01 +0800
committerPeng Huang <shawn.p.huang@gmail.com>2010-08-17 15:04:42 +0900
commitf3f325b0603ed635d076a5e6430164b2c72b21da (patch)
treeb5972ff6a55a6b6ccf7db4393e788ab1e375b703 /src/Makefile.am
parenta32d2b4d5194559b4601cf7e2c65ddc68bdf13e3 (diff)
downloadibus-libpinyin-f3f325b0603ed635d076a5e6430164b2c72b21da.tar.gz
ibus-libpinyin-f3f325b0603ed635d076a5e6430164b2c72b21da.tar.xz
ibus-libpinyin-f3f325b0603ed635d076a5e6430164b2c72b21da.zip
Add PY prefix of all file names to avoid name conflict on some file
system than is case insensitive.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am124
1 files changed, 62 insertions, 62 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 9490ee0..d1666fc 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -42,73 +42,73 @@ ibus_engine_pinyin_built_h_sources = \
SimpTradConverterTable.h \
$(NULL)
ibus_engine_pinyin_c_sources = \
- BopomofoEditor.cc \
- BopomofoEngine.cc \
- Config.cc \
- Database.cc \
- DoublePinyinEditor.cc \
- Editor.cc \
- Engine.cc \
- FallbackEditor.cc \
- FullPinyinEditor.cc \
- HalfFullConverter.cc \
- Main.cc \
- PhoneticEditor.cc \
- PhraseEditor.cc \
- PinyinEditor.cc \
- PinyinEngine.cc \
- PinyinParser.cc \
- PinyinProperties.cc \
- PunctEditor.cc \
- SimpTradConverter.cc \
- DynamicSpecialPhrase.cc \
- SpecialPhrase.cc \
- SpecialPhraseTable.cc \
+ PYBopomofoEditor.cc \
+ PYBopomofoEngine.cc \
+ PYConfig.cc \
+ PYDatabase.cc \
+ PYDoublePinyinEditor.cc \
+ PYEditor.cc \
+ PYEngine.cc \
+ PYFallbackEditor.cc \
+ PYFullPinyinEditor.cc \
+ PYHalfFullConverter.cc \
+ PYMain.cc \
+ PYPhoneticEditor.cc \
+ PYPhraseEditor.cc \
+ PYPinyinEditor.cc \
+ PYPinyinEngine.cc \
+ PYPinyinParser.cc \
+ PYPinyinProperties.cc \
+ PYPunctEditor.cc \
+ PYSimpTradConverter.cc \
+ PYDynamicSpecialPhrase.cc \
+ PYSpecialPhrase.cc \
+ PYSpecialPhraseTable.cc \
$(NULL)
ibus_engine_pinyin_h_sources = \
- Bopomofo.h \
- BopomofoEditor.h \
- BopomofoEngine.h \
- Bus.h \
- Config.h \
- Database.h \
- DoublePinyinEditor.h \
- DoublePinyinTable.h \
- Editor.h \
- Engine.h \
- ExtEditor.h \
- FallbackEditor.h \
- FullPinyinEditor.h \
- HalfFullConverter.h \
- LookupTable.h \
- Object.h \
- PhoneticEditor.h \
- Phrase.h \
- PhraseArray.h \
- PhraseEditor.h \
- PinyinArray.h \
- PinyinEditor.h \
- PinyinEngine.h \
- PinyinParser.h \
- PinyinProperties.h \
- Pointer.h \
- Property.h \
- PunctEditor.h \
- RawEditor.h \
- Regex.h \
- Signal.h \
- SimpTradConverter.h \
- SpecialPhrase.h \
- DynamicSpecialPhrase.h \
- SpecialPhraseTable.h \
- String.h \
- Text.h \
- Types.h \
- Util.h \
+ PYBopomofo.h \
+ PYBopomofoEditor.h \
+ PYBopomofoEngine.h \
+ PYBus.h \
+ PYConfig.h \
+ PYDatabase.h \
+ PYDoublePinyinEditor.h \
+ PYDoublePinyinTable.h \
+ PYEditor.h \
+ PYEngine.h \
+ PYExtEditor.h \
+ PYFallbackEditor.h \
+ PYFullPinyinEditor.h \
+ PYHalfFullConverter.h \
+ PYLookupTable.h \
+ PYObject.h \
+ PYPhoneticEditor.h \
+ PYPhrase.h \
+ PYPhraseArray.h \
+ PYPhraseEditor.h \
+ PYPinyinArray.h \
+ PYPinyinEditor.h \
+ PYPinyinEngine.h \
+ PYPinyinParser.h \
+ PYPinyinProperties.h \
+ PYPointer.h \
+ PYProperty.h \
+ PYPunctEditor.h \
+ PYRawEditor.h \
+ PYRegex.h \
+ PYSignal.h \
+ PYSimpTradConverter.h \
+ PYSpecialPhrase.h \
+ PYDynamicSpecialPhrase.h \
+ PYSpecialPhraseTable.h \
+ PYString.h \
+ PYText.h \
+ PYTypes.h \
+ PYUtil.h \
$(NULL)
if IBUS_BUILD_LUA_EXTENSION
-ibus_engine_pinyin_c_sources += ExtEditor.cc
+ibus_engine_pinyin_c_sources += PYExtEditor.cc
endif
ibus_engine_pinyin_SOURCES = \