summaryrefslogtreecommitdiffstats
path: root/setup/Makefile.am
diff options
context:
space:
mode:
authorPeng Wu <alexepico@gmail.com>2013-02-07 11:44:41 +0800
committerPeng Wu <alexepico@gmail.com>2013-02-07 11:51:26 +0800
commit4b26bca531a13aec957d0568f7d1696ce6a04d52 (patch)
tree2cbfc2d62713acb5df3347ef1a9940ae0ebd282d /setup/Makefile.am
parent10375d1dc8c3943d7520129e14be05873e920f7d (diff)
downloadibus-libpinyin-4b26bca531a13aec957d0568f7d1696ce6a04d52.tar.gz
ibus-libpinyin-4b26bca531a13aec957d0568f7d1696ce6a04d52.tar.xz
ibus-libpinyin-4b26bca531a13aec957d0568f7d1696ce6a04d52.zip
update autoconf
Diffstat (limited to 'setup/Makefile.am')
-rw-r--r--setup/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/setup/Makefile.am b/setup/Makefile.am
index 7845342..64a8f1d 100644
--- a/setup/Makefile.am
+++ b/setup/Makefile.am
@@ -40,6 +40,11 @@ EXTRA_DIST = \
ibus-setup-libpinyin.in \
$(NULL)
+
+config.py: config.py.in
+ $(SED) -e "s:[@]VERSION@:$(VERSION):" \
+ -e "s:[@]datadir@:$(datadir)/$(PACKAGE):" $< > $@
+
test-libpinyin:
$(ENV) DBUS_DEBUG=true \
IBUS_LOCALEDIR=@localedir@ \