summaryrefslogtreecommitdiffstats
path: root/lua/Makefile.am
diff options
context:
space:
mode:
authorPeng Huang <shawn.p.huang@gmail.com>2010-03-31 10:54:40 +0800
committerPeng Wu <alexepico@gmail.com>2010-05-19 10:09:31 +0800
commitc99ffc77af565bbe84981fa8b9fd881a21dd5f42 (patch)
treeb2a5a9a1953a4e63fc9d141806ceb3038c644cda /lua/Makefile.am
parent8f63f9f3362e97377bcad584ecb5fb4ac75d5223 (diff)
downloadibus-libpinyin-c99ffc77af565bbe84981fa8b9fd881a21dd5f42.tar.gz
ibus-libpinyin-c99ffc77af565bbe84981fa8b9fd881a21dd5f42.tar.xz
ibus-libpinyin-c99ffc77af565bbe84981fa8b9fd881a21dd5f42.zip
Integrate lua
Diffstat (limited to 'lua/Makefile.am')
-rw-r--r--lua/Makefile.am59
1 files changed, 59 insertions, 0 deletions
diff --git a/lua/Makefile.am b/lua/Makefile.am
new file mode 100644
index 0000000..bcf3803
--- /dev/null
+++ b/lua/Makefile.am
@@ -0,0 +1,59 @@
+# vim:set noet ts=4:
+#
+# ibus-pinyin - The Chinese PinYin engine for IBus
+#
+# Copyright (c) 2007-2008 Peng Huang <shawn.p.huang@gmail.com>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2, or (at your option)
+# any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+
+noinst_LTLIBRARIES = \
+ libpylua.la \
+ $(NULL)
+
+libpylua_la_SOURCES = \
+ lua-plugin.h \
+ lua-plugin-init.c \
+ $(NULL)
+
+libpylua_la_CFLAGS = \
+ @IBUS_CFLAGS@ \
+ @LUA_CFLAGS@ \
+ $(NULL)
+
+libpylua_la_LIBADD = \
+ @IBUS_LIBS@ \
+ @LUA_LIBS@ \
+ $(NULL)
+
+TESTS = \
+ test-lua-plugin \
+ $(NULL)
+
+noinst_PROGRAMS = \
+ $(TESTS) \
+ $(NULL)
+
+test_lua_plugin_SOURCES = \
+ test-lua-plugin.c \
+ $(NULL)
+
+test_lua_plugin_CFLAGS = \
+ @IBUS_CFLAGS@ \
+ @LUA_CFLAGS@ \
+ $(NULL)
+
+test_lua_plugin_LDADD = \
+ libpylua.la \
+ $(NULL)