summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPetr Viktorin <pviktori@redhat.com>2015-02-02 10:39:36 +0100
committerPetr Viktorin <pviktori@redhat.com>2015-02-02 10:39:36 +0100
commit5b2ca650b21d60a481e861ce998d2a0bbd2fb64d (patch)
tree1e279847bd724abdc2df428034e135566d9a3873 /configure.ac
parent1bc034eaa38e56c9b9fc0151b9d56cfe3912af29 (diff)
downloadibus-libpinyin-5b2ca650b21d60a481e861ce998d2a0bbd2fb64d.tar.gz
ibus-libpinyin-5b2ca650b21d60a481e861ce998d2a0bbd2fb64d.tar.xz
ibus-libpinyin-5b2ca650b21d60a481e861ce998d2a0bbd2fb64d.zip
Enable running setup scripts with Python 3
The default uses 'python'. To use 'python3', ./configure --with-python=python3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6cbd8ef..3a41809 100644
--- a/configure.ac
+++ b/configure.ac
@@ -86,6 +86,11 @@ AC_PATH_PROG(ENV, env)
AC_SUBST(ENV)
# check python
+AC_ARG_WITH(python,
+ AS_HELP_STRING([--with-python[=PATH]],
+ [Select python2 or python3]),
+ [PYTHON=$with_python], []
+)
AM_PATH_PYTHON([2.5])
# --enable-boost