summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPeng Huang <shawn.p.huang@gmail.com>2010-05-26 13:21:34 +0800
committerPeng Huang <shawn.p.huang@gmail.com>2010-05-26 13:44:16 +0800
commit6d232faeef299048a2d2d4f02aa36614a40e4cc0 (patch)
tree5984a0a673ee3f6c6aed776a079a017b6e454a10 /Makefile.am
parent0ba1b74b141c445832c64a17945830aa2da277ee (diff)
downloadibus-libpinyin-6d232faeef299048a2d2d4f02aa36614a40e4cc0.tar.gz
ibus-libpinyin-6d232faeef299048a2d2d4f02aa36614a40e4cc0.tar.xz
ibus-libpinyin-6d232faeef299048a2d2d4f02aa36614a40e4cc0.zip
Add ppa target for generate debian source packages.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 236ed89..47bc183 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -70,6 +70,33 @@ srpm: dist @PACKAGE_NAME@.spec
--define "_rpmdir `pwd`/rpm" \
--define "_specdir `pwd`" \
@PACKAGE_NAME@.spec
+
+.PHONY: debian/changelog
+debian/changelog:
+ $(AM_V_GEN) \
+ ( \
+ date=`date -R`; \
+ version=@VERSION@; \
+ serie=$(serie); \
+ if test -z "$$serie"; then \
+ serie=lucid; \
+ fi; \
+ s=`cat debian/changelog.in`; \
+ eval "echo \"$${s}\""; \
+ ) > $@
+
+ppa: dist debian/changelog
+ $(AM_V_GEN) \
+ ( \
+ mkdir ppa; \
+ cd ppa; \
+ tar zxvf ../$(distdir).tar.gz ; \
+ cd $(distdir); \
+ cp -a ../../debian . ; \
+ cd debian; \
+ debuild -S -sa ; \
+ )
+
upload: dist
./tools/googlecode_upload.py \
-s "ibus-pinyin(拼音)source code" \