summaryrefslogtreecommitdiffstats
path: root/third_party/pyiso8601/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/pyiso8601/setup.py')
-rw-r--r--third_party/pyiso8601/setup.py25
1 files changed, 25 insertions, 0 deletions
diff --git a/third_party/pyiso8601/setup.py b/third_party/pyiso8601/setup.py
new file mode 100644
index 0000000000..e9dc75dfd4
--- /dev/null
+++ b/third_party/pyiso8601/setup.py
@@ -0,0 +1,25 @@
+import os
+
+try:
+ from setuptools import setup
+except ImportError:
+ from distutils import setup
+
+long_description = open(os.path.join(os.path.dirname(__file__), "README.rst")).read()
+
+setup(
+ name="iso8601",
+ version="0.1.11",
+ description=long_description.split("\n")[0],
+ long_description=long_description,
+ author="Michael Twomey",
+ author_email="micktwomey+iso8601@gmail.com",
+ url="https://bitbucket.org/micktwomey/pyiso8601",
+ packages=["iso8601"],
+ license="MIT",
+ classifiers=[
+ "License :: OSI Approved :: MIT License",
+ "Programming Language :: Python :: 2",
+ "Programming Language :: Python :: 3",
+ ],
+)