summaryrefslogtreecommitdiffstats
path: root/tcsh.spec
diff options
context:
space:
mode:
Diffstat (limited to 'tcsh.spec')
-rw-r--r--tcsh.spec69
1 files changed, 29 insertions, 40 deletions
diff --git a/tcsh.spec b/tcsh.spec
index 46eb83f..68b1879 100644
--- a/tcsh.spec
+++ b/tcsh.spec
@@ -1,29 +1,29 @@
Summary: An enhanced version of csh, the C shell
Name: tcsh
-Version: 6.18.01
-Release: 10%{?dist}
+Version: 6.18.02
+Release: 1%{?dist}
License: BSD
Group: System Environment/Shells
Source: http://ftp.funet.fi/pub/unix/shells/tcsh/%{name}-%{version}.tar.gz
-Patch1: tcsh-6.15.00-closem.patch
-Patch2: tcsh-6.14.00-tinfo.patch
-Patch3: tcsh-6.14.00-unprintable.patch
-Patch4: tcsh-6.15.00-hist-sub.patch
-Patch8: tcsh-6.14.00-syntax.patch
-Patch9: tcsh-6.13.00-memoryuse.patch
-Patch11: tcsh-6.14.00-order.patch
-# Proposed upstream - http://github.com/tcsh-org/tcsh/pull/1
-Patch28: tcsh-6.17.00-manpage-spelling.patch
+
+# Those patches here should be in git format and are commented inside.
+
+Patch1: tcsh-6.18.02-closem.patch
+Patch2: tcsh-6.18.02-tinfo.patch
+Patch3: tcsh-6.18.02-unprintable.patch
+Patch4: tcsh-6.18.02-syntax.patch
+Patch5: tcsh-6.18.02-memoryuse.patch
+Patch6: tcsh-6.18.02-order.patch
+Patch7: tcsh-6.18.02-fixgencat.patch
+Patch8: tcsh-6.18.02-hist-sub.patch
+Patch9: tcsh-6.18.02-elf-interpreter.patch
+Patch10: tcsh-6.18.02-posix-exit-status-value.patch
+
+# TODO: review better upstream file locking
# Proposed upstream - http://github.com/tcsh-org/tcsh/pull/2
-Patch31: tcsh-6.18.00-history-file-locking.patch
-# Accepted upstream - http://mx.gw.com/pipermail/tcsh-bugs/2012-December/000797.html
-#Patch32: tcsh-6.18.00-sigint-while-waiting-for-child.patch
-Patch33: tcsh-6.18.00-history-merge.patch
-Patch34: tcsh-6.18.01-repeated-words-man.patch
-# Proposed upstream - http://mx.gw.com/pipermail/tcsh-bugs/2013-April/000833.html
-Patch35: tcsh-6.18.01-elf-interpreter.patch
-Patch36: tcsh-6.18.01-posix-exit-status-value.patch
-Patch37: tcsh-6.18.01-reverse-history-handling-in-loops.patch
+# Patch31: tcsh-6.18.00-history-file-locking.patch
+# Patch33: tcsh-6.18.00-history-merge.patch
+# Patch37: tcsh-6.18.01-reverse-history-handling-in-loops.patch
Provides: csh = %{version}
Provides: /bin/tcsh, /bin/csh
@@ -42,35 +42,18 @@ spelling correction, a history mechanism, job control and a C language
like syntax.
%prep
-%setup -q -n %{name}-%{version}
-%patch1 -p1 -b .closem
-%patch2 -p1 -b .tinfo
-%patch3 -p1 -b .unprintable
-%patch4 -p1 -b .hist-sub
-%patch8 -p1 -b .syntax
-%patch9 -p1 -b .memoryuse
-%patch11 -p1 -b .order
-%patch28 -p1 -b .manpage-spelling
-%patch31 -p1 -b .history-file-locking
-#%%patch32 -p1 -b .sigint-while-waiting-for-child
-%patch33 -p1 -b .history-merge
-%patch34 -p1 -b .repeated-words-man
-%patch35 -p1 -b .elf-interpreter
-%patch36 -p1 -b .posix-exit-status-value
-%patch37 -p1 -b .reverse-history-handling-in-loops
+%autosetup -p1
for i in Fixes WishList; do
iconv -f iso-8859-1 -t utf-8 "$i" > "${i}_" && \
touch -r "$i" "${i}_" && \
mv "${i}_" "$i"
done
+autoreconf
%build
-# For tcsh-6.14.00-tinfo.patch
-autoreconf
%configure --without-hesiod
-make %{?_smp_mflags} all
-make %{?_smp_mflags} -C nls catalogs
+make %{?_smp_mflags}
%install
rm -rf $RPM_BUILD_ROOT
@@ -102,6 +85,9 @@ ru russian
uk ukrainian
_EOF
+%check
+make check
+
%clean
rm -rf $RPM_BUILD_ROOT
@@ -131,6 +117,9 @@ fi
%{_mandir}/man1/*.1*
%changelog
+* Thu Jul 24 2014 Pavel Raiskup <praiskup@redhat.com> - 6.18.02-1
+- rebase to most recent upstream version (beta, prepare for 6.19)
+
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 6.18.01-10
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild