summaryrefslogtreecommitdiffstats
path: root/repos/autotools/autotools-latest/libtool/libtool.spec
diff options
context:
space:
mode:
Diffstat (limited to 'repos/autotools/autotools-latest/libtool/libtool.spec')
-rw-r--r--repos/autotools/autotools-latest/libtool/libtool.spec78
1 files changed, 40 insertions, 38 deletions
diff --git a/repos/autotools/autotools-latest/libtool/libtool.spec b/repos/autotools/autotools-latest/libtool/libtool.spec
index 203edfa..d98fa9c 100644
--- a/repos/autotools/autotools-latest/libtool/libtool.spec
+++ b/repos/autotools/autotools-latest/libtool/libtool.spec
@@ -4,37 +4,33 @@
%{?scl:%global __provides_exclude ^libltdl\\.so.*$}
+# See the bug #1289759
+%undefine _hardened_build
+
+# See the bug #429880
%global gcc_version %(gcc -dumpversion || echo "666")
%{?scl:%scl_package libtool}
+%{!?runselftest:%global runselftest 1}
+%{!?autoreconf:%global autoreconf 0}
+
Summary: The GNU Portable Library Tool
Name: %{?scl_prefix}libtool
-Version: 2.4.2
-Release: 17%{?dist}
+Version: 2.4.6
+Release: 1%{?dist}
License: GPLv2+ and LGPLv2+ and GFDL
URL: http://www.gnu.org/software/libtool/
Group: Development/Tools
Source: http://ftp.gnu.org/gnu/libtool/libtool-%{version}.tar.gz
-# TODO: document reasons for this patch
-# ~> downstream
-Patch0: libtool-2.4.2-rpath.patch
-
-# Disable buggy tests for features we don't support.
# ~> downstream
-Patch1: libtool-2.4.2-disable-tests.patch
+Patch0: libtool-2.4.5-rpath.patch
# Patch to use generated files by newer autotools (this allows us to build the
# package without running autoreconf during build)
-Patch2: libtool-2.4.2-autoreconfed.patch
-
-# Run the 'tar --no-same-owner -xf' instead of 'tar -xf'
-# ~> #740079
-# ~> Downstream - tar is not used in upstream 'master' branch anymore, will be
-# fixed in next release.
-Patch3: libtool-2.4.2-tar-no-owner.patch
+Patch2: libtool-2.4.6-autoreconf.patch
# /usr/bin/libtool includes paths within gcc's versioned directories
# Libtool must be rebuilt whenever a new upstream gcc is built
@@ -45,19 +41,15 @@ Requires(preun): /sbin/install-info
BuildRequires: help2man
BuildRequires: texinfo
+%if 0%{?autoreconf}
+BuildRequires: %{scl_prefix}autoconf, %{scl_prefix}automake
+%endif
%{?scl:
BuildRequires: scl-utils-build %{scl_prefix}runtime
Requires:%scl_runtime
}
-%if ! 0%{?buildroot:1}
-# HACK! This should be truth only for RHEL5, so benefit from
-# this %%if for defining (otherwise undefined) macro for this platform.
-%global rhel 5
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-%endif
-
# make sure we can configure all supported langs
BuildRequires: libstdc++-devel, gcc-gfortran
@@ -81,6 +73,7 @@ and GNU Automake).
%package ltdl
Summary: Runtime libraries for GNU Libtool Dynamic Module Loader
Group: System Environment/Libraries
+Provides: %{?scl_prefix}%{name}-libs%{_isa} = %{version}-%{release}
License: LGPLv2+
Requires(post): /sbin/ldconfig
Requires(postun): /sbin/ldconfig
@@ -111,12 +104,17 @@ Static libraries and header files for development with ltdl.
%setup -q -n libtool-%version
%patch0 -p1 -b .rpath
-%patch1 -p1 -b .disable-test
-%patch2 -p1 -b .autoreconfed
-%patch3 -p1 -b .nosameowner
+%if 0%{?autoreconf}
+%{?scl_heredoc}
+autoreconf -v
+%{?scl_heredoc_off}
+%else
+%patch2 -p1 -b .autoreconfed
# to use this, we should 100% *know* what the patches do
find -exec touch --date=`date -I` {} +
+%endif
+
%build
@@ -126,6 +124,9 @@ export CXX=g++
export F77=gfortran
export CFLAGS="$RPM_OPT_FLAGS -fPIC"
+# rhbz#1214506
+%global _configure_libtool_hardening_hack 0
+
%configure --prefix=%{_prefix} \
--exec-prefix=%{_prefix} \
--bindir=%{_bindir} \
@@ -137,30 +138,24 @@ export CFLAGS="$RPM_OPT_FLAGS -fPIC"
--libexecdir=%{_libexecdir} \
--localstatedir=%{_localstatedir} \
--mandir=%{_mandir} \
- --infodir=%{_infodir} \
- --host= --build= --target=
+ --infodir=%{_infodir}
make %{?_smp_mflags}
%{?scl_heredoc_off}
-for i in ChangeLog.1997 ChangeLog.1998 ChangeLog.1999 ChangeLog.2002; do
- iconv -f ISO_8859-15 -t UTF8 $i > $i.tmp
- mv -f $i.tmp $i
-done
-
%check
-# make check VERBOSE=yes
+%if 0%{?runselftest}
+make check VERBOSE=yes || { cat tests/testsuite.log ; true ; }
+%endif
%install
%{?scl_heredoc}
%_compat_install
make install DESTDIR=%{buildroot}
-
# info's TOP dir (by default owned by info)
rm -f %{buildroot}%{_infodir}/dir
-
# *.la *.a files generated by libtool shouldn't be distributed (and the
# `./configure --disable-static' breaks testsuite)
rm -f %{buildroot}%{_libdir}/libltdl.{a,la}
@@ -190,22 +185,29 @@ fi
%{_bindir}/libtool
%{_bindir}/libtoolize
%{_datadir}/aclocal/*.m4
-%exclude %{_datadir}/libtool/libltdl
-%{_datadir}/libtool
+%dir %{_datadir}/libtool
+%{_datadir}/libtool/build-aux
+
%files ltdl
%doc libltdl/COPYING.LIB
%{_libdir}/libltdl.so.*
+
%files ltdl-devel
%doc libltdl/README
-%{_datadir}/libtool/libltdl
+%{_datadir}/libtool
+%exclude %{_datadir}/libtool/build-aux
%{_includedir}/ltdl.h
%{_includedir}/libltdl
# .so files without version must be in -devel subpackage
%{_libdir}/libltdl.so
+
%changelog
+* Fri Jun 17 2016 Pavel Raiskup <praiskup@redhat.com> - 2.4.6-12
+- rebase and rebuild for new gcc, sync with fedora rawhide
+
* Tue Jun 14 2016 Pavel Raiskup <praiskup@redhat.com> - 2.4.2-17
- rebuild for new gcc versions