summaryrefslogtreecommitdiffstats
path: root/repos/autotools/autotools-git/automake/automake.spec
diff options
context:
space:
mode:
Diffstat (limited to 'repos/autotools/autotools-git/automake/automake.spec')
-rw-r--r--repos/autotools/autotools-git/automake/automake.spec85
1 files changed, 44 insertions, 41 deletions
diff --git a/repos/autotools/autotools-git/automake/automake.spec b/repos/autotools/autotools-git/automake/automake.spec
index d072d01..b0cb0a4 100644
--- a/repos/autotools/autotools-git/automake/automake.spec
+++ b/repos/autotools/autotools-git/automake/automake.spec
@@ -1,10 +1,6 @@
%{?_compat_el5_build}
-# this is needed for el5 builders
-%global _source_filedigest_algorithm md5
-
-# Workaround to always have %scl defined (for testing locally)
-
+# Workaround to always have %%scl defined (for testing locally)
%{!?scl:%global scl autotools-git}
%{?scl:%scl_package automake}
@@ -18,26 +14,19 @@
Summary: A GNU tool for automatically creating Makefiles
Name: %{?scl_prefix}automake
Version: %{api_version}a
-Release: 12.%git_tag%{?dist}
+Release: 13.%git_tag%{?dist}
# docs ~> GFDL, sources ~> GPLv2+, mkinstalldirs ~> PD and install-sh ~> MIT
License: GPLv2+ and GFDL and Public Domain and MIT
Group: Development/Tools
Source: ftp://ftp.gnu.org/gnu/automake/automake-%{version}.tar.gz
+Source2: http://git.savannah.gnu.org/cgit/config.git/plain/config.sub
+Source3: http://git.savannah.gnu.org/cgit/config.git/plain/config.guess
-# Disable tests for broken vala installation
-# ~> downstream
-Patch0: automake-1.13.1-disable-tests.patch
-
-# Something changed in Perl 5.18 and the testsuite started to fail because
-# of random looping in hashes items. Upstream will probably start sorting of
-# hash items by default for this failing case ~> we just don't resist on its
-# order for now (only testsuite change).
-# ~> Downstream, but proper fix will be pushed:
-# http://lists.gnu.org/archive/html/bug-automake/2013-07/msg00030.html
-# ~> http://lists.gnu.org/archive/html/bug-automake/2013-07/msg00022.html
-Patch1: automake-1.14-hash-order-workaround.patch
+# Keep those patches in 'git format-patch' format (with docs).
+Patch0: automake-1.15-disable-vala-tests.patch
+Patch1: automake-1.15-perl-escape-curly-bracket.patch
URL: http://www.gnu.org/software/automake/
Requires: %{?scl_prefix}autoconf >= 2.65
@@ -46,22 +35,12 @@ Requires: %{?scl_prefix}autoconf >= 2.65
Requires: perl(Thread::Queue)
Requires: perl(threads)
-# This is needed to allow 'help2man' to run 'automake --help' during build.
-BuildRequires: perl(Thread::Queue)
-
Requires(post): /sbin/install-info
Requires(preun): /sbin/install-info
BuildArch: noarch
-%if ! 0%{?buildroot:1}
-# HACK! This should be truth only for RHEL5, so benefit from
-# this %%if for defining (otherwise undefined) macro for this platform.
-%global rhel 5
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-%endif
-
# run "make check" by default
-%bcond_without check
+%bcond_with check
%{?scl:
BuildRequires: scl-utils-build
@@ -90,10 +69,6 @@ BuildRequires: cscope ncompress sharutils help2man
BuildRequires: gcc-objc gcc-objc++
%if !0%{?rhel:1}
BuildRequires: python-virtualenv lzip
-%if 0%{?fedora} < 21
-# gcc-java was disabled in RHEL >= 7 and Fedora >= 21
-BuildRequires: gcc-java
-%endif
%endif
%endif
@@ -108,6 +83,8 @@ BuildRequires: perl-devel
%endif
%endif
+# This is needed to allow 'help2man' to run 'automake --help' during build.
+BuildRequires: perl(Thread::Queue)
%if ! 0%{?rhel} == 5
# remove bogus Automake perl dependencies and provides
@@ -115,6 +92,7 @@ BuildRequires: perl-devel
%global __provides_exclude %{?__provides_exclude:%__provides_exclude|}^perl\\(Automake::
%endif
+
%description
Automake is a tool for automatically generating `Makefile.in'
files compliant with the GNU Coding Standards.
@@ -126,40 +104,60 @@ Makefiles.
%prep
%setup -q -n automake-%{version}
%patch0 -p1 -b .disable_tests
-%patch1 -p1 -b .hash_order
+%patch1 -p1 -b .curly_bracket
# to use this, we should 100% *know* what the patches do
find -exec touch --date=`date -I` {} +
+file=`find -name config.sub | head -1`
+cp %{SOURCE2} $file
+file=`find -name config.guess | head -1`
+cp %{SOURCE3} $file
+
# Fedora only to add ppc64p7 (Power7 optimized) arch:
perl -pi -e "s/ppc64-\*/ppc64-\* \| ppc64p7-\*/" lib/config.sub
%build
-# TODO: use %%configure once #991613
+%if 0%{?fedora} >= 21
+# disable replacing config.guess and config.sub from redhat-rpm-config
+%global _configure_gnuconfig_hack 0
+scl enable autotools-git - <<\EOF
+%configure --docdir=%{_pkgdocdir}
+make %{?_smp_mflags}
+EOF
+%else
+# Use ./configure where rhbz#991613 is not fixed
scl enable autotools-git - <<EOF
./configure --prefix=%{_prefix} --mandir=%{_mandir} --infodir=%{_infodir} \
--bindir=%{_bindir} --datadir=%{_datadir} --libdir=%{_libdir} \
--docdir=%{_pkgdocdir} --disable-silent-rules
make V=0 %{?_smp_mflags}
+EOF
+%endif
+
cp m4/acdir/README README.aclocal
cp contrib/multilib/README README.multilib
-EOF
%install
-%if 0%{?rhel} == 5
-rm -rf %{builroot}
-%endif
+%_compat_install
scl enable autotools-git - <<EOF
make install DESTDIR=%{buildroot}
EOF
-rm -rf %{buildroot}%{_infodir}/dir
+
+# %%doc is broken on older RHEL systems so that even if we set --docdir to
+# %%_pkgdocdir by configure, procesing of %%doc removes whole %%_pkgdocdir and
+# then it is filled by %%doc (relative) files. This causes that amhello gets
+# removed.
+mv %{buildroot}/%{_pkgdocdir}/amhello* .
+# Fail if non-empty!
+rmdir %{buildroot}/%{_pkgdocdir}
%check
# %%global TESTS_FLAGS t/preproc-errmsg t/preproc-basics
%if %{with check}
make -k %{?_smp_mflags} check %{?TESTS_FLAGS: TESTS="%{TESTS_FLAGS}"} \
- || ( cat ./test-suite.log && true )
+ || ( cat ./test-suite.log && false )
%endif
%post
@@ -172,6 +170,8 @@ fi
%files
%doc AUTHORS README THANKS NEWS README.aclocal README.multilib COPYING*
+%doc amhello-1.0.tar.gz
+%exclude %{_infodir}/dir
%exclude %{_datadir}/aclocal
%{_bindir}/*
%{_infodir}/*.info*
@@ -180,6 +180,9 @@ fi
%{_mandir}/man1/*
%changelog
+* Wed Aug 12 2015 Pavel Raiskup <praiskup@redhat.com> - 1.99a-13.904253
+- sync with autotools-latest
+
* Wed Aug 12 2015 Pavel Raiskup <praiskup@redhat.com> - 1.99a-12.904253
- use _compat_el5_build only if defined (rhbz#1252751)