summaryrefslogtreecommitdiffstats
path: root/repos/autotools/autotools-git/autoconf/autoconf.spec
diff options
context:
space:
mode:
Diffstat (limited to 'repos/autotools/autotools-git/autoconf/autoconf.spec')
-rw-r--r--repos/autotools/autotools-git/autoconf/autoconf.spec108
1 files changed, 108 insertions, 0 deletions
diff --git a/repos/autotools/autotools-git/autoconf/autoconf.spec b/repos/autotools/autotools-git/autoconf/autoconf.spec
new file mode 100644
index 0000000..c2a46f2
--- /dev/null
+++ b/repos/autotools/autotools-git/autoconf/autoconf.spec
@@ -0,0 +1,108 @@
+# Workaround to always have %scl defined (for testing locally)
+%{!?scl:%global scl autotools-git}
+
+%global commits_from_release 117
+%global git_hash 1717
+
+%{?scl:%scl_package autoconf}
+
+Summary: A GNU tool for automatically configuring source code
+Name: %{scl_prefix}autoconf
+Version: 2.69
+Release: 1.%{commits_from_release}.%{git_hash}%{?dist}
+License: GPLv2+ and GFDL
+Group: Development/Tools
+Source0: autoconf-2.69.117-1717-dirty.tar.gz
+URL: http://www.gnu.org/software/autoconf/
+BuildArch: noarch
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+
+# run "make check" by default
+%bcond_without check
+
+# m4 >= 1.4.6 is required, >= 1.4.14 is recommended; We have 1.4.5 in rhel5,
+# 1.4.13 in rhel6, so don't build for el5 yet - this requires workaround with
+# probably empty 'm4' SCLized package for OK platforms, don't know what is
+# proper way.
+BuildRequires: m4 >= 1.4.6
+Requires: m4 >= 1.4.6
+BuildRequires: emacs
+
+BuildRequires: /etc/rpm/macros.perl
+BuildRequires: perl(Data::Dumper)
+# from f19, Text::ParseWords is not the part of 'perl' package
+BuildRequires: perl(Text::ParseWords)
+BuildRequires: scl-utils-build
+
+%if %{with check}
+# For extended testsuite coverage
+BuildRequires: gcc-gfortran
+%if 0%{?fedora} >= 15
+BuildRequires: erlang
+%endif
+%endif
+
+Requires(post): /sbin/install-info
+Requires(preun): /sbin/install-info
+
+# filter out bogus perl(Autom4te*) dependencies
+%global __requires_exclude %{?__requires_exclude:%__requires_exclude|}^perl\\(Autom4te::
+%global __provides_exclude %{?__provides_exclude:%__provides_exclude|}^perl\\(Autom4te::
+
+%description
+GNU's Autoconf is a tool for configuring source code and Makefiles.
+Using Autoconf, programmers can create portable and configurable
+packages, since the person building the package is allowed to
+specify various configuration options.
+
+You should install Autoconf if you are developing software and
+would like to create shell scripts that configure your source code
+packages. If you are installing Autoconf, you will also need to
+install the GNU m4 package.
+
+Note that the Autoconf package is not required for the end-user who
+may be configuring software with an Autoconf-generated script;
+Autoconf is only required for the generation of the scripts, not
+their use.
+
+%prep
+%setup -q -n autoconf-%{version}.%{commits_from_release}-%{git_hash}-dirty
+
+%build
+%configure
+# not parallel safe
+make
+
+%check
+%if %{without check}
+make check # TESTSUITEFLAGS='1-198 200-' # will disable nr. 199.
+%endif
+
+%install
+make install DESTDIR=%{buildroot}
+mkdir -p %{buildroot}/share
+
+%post
+/sbin/install-info %{_infodir}/autoconf.info %{_infodir}/dir || :
+
+%preun
+if [ "$1" = 0 ]; then
+ /sbin/install-info --del %{_infodir}/autoconf.info %{_infodir}/dir || :
+fi
+
+%files
+%{_bindir}/*
+%{_infodir}/autoconf.info*
+# don't include standards.info, because it comes from binutils...
+%exclude %{_infodir}/standards*
+# don't include info's TOP directory
+%exclude %{_infodir}/dir
+%{_datadir}/autoconf/
+%dir %{_datadir}/emacs/
+%{_datadir}/emacs/site-lisp/
+%{_mandir}/man1/*
+%doc AUTHORS COPYING* ChangeLog NEWS README THANKS TODO
+
+%changelog
+* Wed Mar 19 2014 Pavel Raiskup <praiskup@redhat.com> - 2.69-1.117.1717
+- SCL-ized spec file from Rawhide, no testsuite enabled yet