summaryrefslogtreecommitdiffstats
path: root/repos/autotools/autotools-latest/automake/automake.spec
diff options
context:
space:
mode:
authorPavel Raiskup <praiskup@redhat.com>2014-03-21 18:09:05 +0100
committerPavel Raiskup <praiskup@redhat.com>2014-03-21 18:09:05 +0100
commit626d514562da3bfa95b99cebcd50248c14566873 (patch)
tree4a0b0ece8819144cc878b9afee9e807f1ef28f3d /repos/autotools/autotools-latest/automake/automake.spec
parent9741a3ab1949417fb5bf988622f5bb903437393f (diff)
downloadscl-autotools-626d514562da3bfa95b99cebcd50248c14566873.tar.gz
scl-autotools-626d514562da3bfa95b99cebcd50248c14566873.tar.xz
scl-autotools-626d514562da3bfa95b99cebcd50248c14566873.zip
autotools-latest/automake: initialize
Diffstat (limited to 'repos/autotools/autotools-latest/automake/automake.spec')
-rw-r--r--repos/autotools/autotools-latest/automake/automake.spec153
1 files changed, 153 insertions, 0 deletions
diff --git a/repos/autotools/autotools-latest/automake/automake.spec b/repos/autotools/autotools-latest/automake/automake.spec
new file mode 100644
index 0000000..ed9398d
--- /dev/null
+++ b/repos/autotools/autotools-latest/automake/automake.spec
@@ -0,0 +1,153 @@
+%{!?scl:%global scl autotools-latest}
+
+%{?scl:%scl_package automake}
+
+%global api_version 1.14
+
+# remove once %%configure is used instead of ./configure
+%{!?_pkgdocdir: %global _pkgdocdir %{_docdir}/%{name}-%{version}}
+
+Summary: A GNU tool for automatically creating Makefiles
+Name: %{?scl_prefix}automake
+Version: %{api_version}.1
+Release: 1%{?dist}
+
+# docs ~> GFDL, sources ~> GPLv2+, mkinstalldirs ~> PD and install-sh ~> MIT
+License: GPLv2+ and GFDL and Public Domain and MIT
+
+Group: Development/Tools
+Source: ftp://ftp.gnu.org/gnu/automake/automake-%{version}.tar.gz
+
+# Disable tests for broken vala installation
+# ~> downstream
+Patch0: automake-1.13.1-disable-tests.patch
+
+# Something changed in Perl 5.18 and the testsuite started to fail because
+# of random looping in hashes items. Upstream will probably start sorting of
+# hash items by default for this failing case ~> we just don't resist on its
+# order for now (only testsuite change).
+# ~> Downstream, but proper fix will be pushed:
+# http://lists.gnu.org/archive/html/bug-automake/2013-07/msg00030.html
+# ~> http://lists.gnu.org/archive/html/bug-automake/2013-07/msg00022.html
+Patch1: automake-1.14-hash-order-workaround.patch
+
+Patch2: automake-1.14.1-autoreconf.patch
+
+URL: http://www.gnu.org/software/automake/
+Requires: %{?scl_prefix}autoconf >= 2.65
+
+# requirements not detected automatically (#919810)
+Requires: perl(Thread::Queue)
+Requires: perl(threads)
+
+Requires(post): /sbin/install-info
+Requires(preun): /sbin/install-info
+BuildArch: noarch
+
+# run "make check" by default
+%bcond_with check
+
+%{?scl:
+BuildRequires: scl-utils-build
+Requires: %scl_runtime
+}
+
+BuildRequires: %{scl_prefix}autoconf
+
+# for better tests coverage:
+%if %{with check}
+#TODO: add libtool from SCL
+BuildRequires: gettext-devel flex bison texinfo-tex texlive-dvips
+BuildRequires: java-devel-openjdk gcc-gfortran
+# /usr/bin/g77 is not in RHEL7
+%if !0%{?rhel}
+%ifnarch %{arm} aarch64
+# g77 is also not present on arm systems
+BuildRequires: /usr/bin/g77
+%endif
+%endif
+BuildRequires: dejagnu expect emacs imake python-docutils vala
+BuildRequires: cscope ncompress sharutils help2man
+BuildRequires: gcc-objc gcc-objc++
+%if !0%{?rhel:1}
+# gcc-java was disabled in RHEL >= 7
+BuildRequires: gcc-java python-virtualenv lzip
+%endif
+%endif
+
+# Filtering macros are in perl-macros (fedora) and (perl-devel rhel6), not in
+# RHEL5
+%if 0%{?fedora} >= 20 || 0%{?rhel} >= 7
+BuildRequires: perl-macros
+%else
+BuildRequires: perl-devel
+%endif
+
+# remove bogus Automake perl dependencies and provides
+%global __requires_exclude %{?__requires_exclude:%__requires_exclude|}^perl\\(Automake::
+%global __provides_exclude %{?__provides_exclude:%__provides_exclude|}^perl\\(Automake::
+
+%description
+Automake is a tool for automatically generating `Makefile.in'
+files compliant with the GNU Coding Standards.
+
+You should install Automake if you are developing software and would
+like to use its ability to automatically generate GNU standard
+Makefiles.
+
+%prep
+%setup -q -n automake-%{version}
+%patch0 -p1 -b .disable_tests
+%patch1 -p1 -b .hash_order
+%patch2 -p1 -b .autoreconf
+
+# to use this, we should 100% *know* what the patches do
+find -exec touch --date=`date -I` {} +
+
+# Fedora only to add ppc64p7 (Power7 optimized) arch:
+perl -pi -e "s/ppc64-\*/ppc64-\* \| ppc64p7-\*/" lib/config.sub
+
+%build
+# TODO: use %%configure once #991613
+scl enable autotools-latest - <<EOF
+./configure --prefix=%{_prefix} --mandir=%{_mandir} --infodir=%{_infodir} \
+ --bindir=%{_bindir} --datadir=%{_datadir} --libdir=%{_libdir} \
+ --docdir=%{_pkgdocdir} --disable-silent-rules
+make V=0 %{?_smp_mflags}
+cp m4/acdir/README README.aclocal
+cp contrib/multilib/README README.multilib
+EOF
+
+%install
+scl enable autotools-git - <<EOF
+make install DESTDIR=%{buildroot}
+EOF
+
+%check
+# %%global TESTS_FLAGS t/preproc-errmsg t/preproc-basics
+%if %{with check}
+make -k %{?_smp_mflags} check %{?TESTS_FLAGS: TESTS="%{TESTS_FLAGS}"} \
+ || ( cat ./test-suite.log && false )
+%endif
+
+%post
+/sbin/install-info %{_infodir}/automake.info.gz %{_infodir}/dir || :
+
+%preun
+if [ $1 = 0 ]; then
+ /sbin/install-info --delete %{_infodir}/automake.info.gz %{_infodir}/dir || :
+fi
+
+%files
+%doc AUTHORS README THANKS NEWS README.aclocal README.multilib COPYING*
+%exclude %{_infodir}/dir
+%exclude %{_datadir}/aclocal
+%{_bindir}/*
+%{_infodir}/*.info*
+%{_datadir}/automake-%{api_version}
+%{_datadir}/aclocal-%{api_version}
+%{_mandir}/man1/*
+
+%changelog
+* Fri Feb 28 2014 Pavel Raiskup <praiskup@redhat.com> - 1.14.1-1
+- copy SCL-ized spec file from autotools-git