summaryrefslogtreecommitdiffstats
path: root/pybugz.spec
diff options
context:
space:
mode:
authorPavel Raiskup <pavel@raiskup.cz>2013-01-20 23:01:05 +0100
committerPavel Raiskup <pavel@raiskup.cz>2013-01-20 23:06:51 +0100
commit7ef456b18416069bfb16f2a73f7555d3c14cb990 (patch)
tree01fdae7ca1aee32fce044418d585fb283d483e41 /pybugz.spec
parente6f9abb9c216294cca988dcff6039a87cd89aed0 (diff)
downloadpybugz-7ef456b18416069bfb16f2a73f7555d3c14cb990.tar.gz
pybugz-7ef456b18416069bfb16f2a73f7555d3c14cb990.tar.xz
pybugz-7ef456b18416069bfb16f2a73f7555d3c14cb990.zip
Fix Merge-Review problems
Diffstat (limited to 'pybugz.spec')
-rw-r--r--pybugz.spec27
1 files changed, 17 insertions, 10 deletions
diff --git a/pybugz.spec b/pybugz.spec
index d35f2b8..28af878 100644
--- a/pybugz.spec
+++ b/pybugz.spec
@@ -1,7 +1,11 @@
+%global gitrev 69cd7
+%global posttag git%{gitrev}
+%global snapshot %{version}-%{posttag}
+
Name: pybugz
Summary: Command line interface for Bugzilla written in Python
-Version: 0.10git69cd7
-Release: 1%{?dist}
+Version: 0.10
+Release: 1.%{posttag}%{?dist}
Group: Applications/Communications
License: GPLv2
URL: https://github.com/williamh/pybugz
@@ -10,9 +14,6 @@ BuildArch: noarch
Requires: python2
BuildRequires: python2-devel
-# we don't need debuginfo package
-%global debug_package %{nil}
-
%if ! 0%{?rhel}
# no bash-completion for RHEL
%global bash_completion 1
@@ -25,12 +26,12 @@ BuildRequires: bash-completion pkgconfig
# There is possible to download upstream tarball generated by github, but it is
# quite old now. For HOWTO obtain correct tarball see the "prepare-tarball.sh"
# script.
-Source0: %{name}-%{version}.tar.gz
+Source0: %{name}-%{snapshot}.tar.gz
# follow https://github.com/praiskup/pybugz changes (until accepted by upstream)
-Patch0: %{name}-%{version}-downstream.patch
+Patch0: %{name}-%{snapshot}-downstream.patch
# make the installation better satisfy RHEL / Fedora purposes
-Patch1: %{name}-%{version}-rhel-fedora-cust.patch
+Patch1: %{name}-%{snapshot}-rhel-fedora-cust.patch
%description
Pybugz was conceived as a tool to speed up the work-flow for Gentoo Linux
@@ -40,7 +41,7 @@ quickly. Developers alike can easily extract attachments and close bugs
comfortably from the command line.
%prep
-%setup -q
+%setup -q -n %{name}-%{snapshot}
%patch0 -p1 -b .downstream
%patch1 -p1 -b .rhel-fedora-cust
@@ -55,7 +56,7 @@ comfortably from the command line.
%if %{?bash_completion}
# find the proper directory to install bash-completion script
mkdir -p %{buildroot}%{bash_cmpl_dir}
- cp %{_builddir}/%{name}-%{version}/contrib/bash-completion \
+ cp %{_builddir}/%{name}-%{snapshot}/contrib/bash-completion \
%{buildroot}%{bash_cmpl_dir}/bugz
%endif
@@ -77,6 +78,12 @@ mkdir -p %{buildroot}%{_docdir}
%doc README LICENSE
%changelog
+* Sun Jan 20 2013 Pavel Raiskup <praiskup@redhat.com> - 0.10-1.git69cd7
+- changes for problems spotted/fixed by Scott Tsai in merge-review bug:
+- important change - move git revision behind the release number
+- reflect that ^^^ change in changelog
+- remove statement disabling debuginfo (it is not needed)
+
* Sun Jan 20 2013 Pavel Raiskup <praiskup@redhat.com> - 0.10git69cd7-1
- apply downstream patches to reflect https://github.com/praiskup/pybugz
it allows hierarchy of configuration files and a bit better error handling