summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 22526f6..6d7971a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -133,12 +133,12 @@ if test -z "$PREVMAJORVERSION"; then
AC_MSG_RESULT($PREVMAJORVERSION)
fi
-if test -z "$PREV_POSTGRES_BIN"; then
- AC_MSG_ERROR([can not detect \$PREV_POSTGRES_BIN])
-fi
-
# Detect PREVPGENGINE
if test -z "$PREVPGENGINE"; then
+ if test -z "$PREV_POSTGRES_BIN"; then
+ AC_MSG_ERROR([can not detect \$PREV_POSTGRES_BIN])
+ fi
+
PREVPGENGINE=`AS_DIRNAME($PREV_POSTGRES_BIN)`
fi