summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPavel Raiskup <praiskup@redhat.com>2014-10-02 18:06:17 +0200
committerPavel Raiskup <praiskup@redhat.com>2014-10-02 18:16:44 +0200
commitaa49c2f1f1f89bca0ca6c6ed5c93c49f6e5c95e5 (patch)
treea32837f9918dd54956a70992506a71cb2fd1bee7 /configure.ac
parent33481db83bb5f6f7d1017e17a00cd0012a06f117 (diff)
downloadpostgresql-setup-aa49c2f1f1f89bca0ca6c6ed5c93c49f6e5c95e5.tar.gz
postgresql-setup-aa49c2f1f1f89bca0ca6c6ed5c93c49f6e5c95e5.tar.xz
postgresql-setup-aa49c2f1f1f89bca0ca6c6ed5c93c49f6e5c95e5.zip
sysvinit: generate init file when needed
From now, if ./configure --with-sysvinit is done, we install init script and do not install systemd files. Original patch written by Jozef MlĂ­ch (jmlich@redhat.com). * Makefile.am (initscriptsdir, nodist_initscripts_DATA): New variables. New postgresql.init target. * configure.ac: Add --with-sysvinit option. * postgresql.init.in: New sysvinit template. * .gitignore: Mention postgresql.init. * NEWS: Document.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a4d0c0f..7cc23df 100644
--- a/configure.ac
+++ b/configure.ac
@@ -17,6 +17,16 @@ AC_CONFIG_FILES([tests/Makefile])
AM_MISSING_PROG([AUTOM4TE], [autom4te])
AC_SUBST([TEST_GEN_FILES_LIST], [.generated_files])
+# TODO: detect systemd/sysvinit. Also, we should probably be able to install
+# both configuration at once when needed.
+AC_ARG_WITH([sysvinit],
+ AS_HELP_STRING([--with-sysvinit],
+ [prepares sys v init script]),
+ [WANT_SYSVINIT=1],
+ [WANT_SYSVINIT=0]
+)
+
+AM_CONDITIONAL([WANT_SYSVINIT], [test "$WANT_SYSVINIT" -eq 1])
# Instatiating generated files by sed instead of config.status.
# This is encouraged by autoconf documentation itself because if we used