summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPavel Raiskup <praiskup@redhat.com>2014-07-01 11:01:03 +0200
committerPavel Raiskup <praiskup@redhat.com>2014-07-01 11:01:03 +0200
commit8c49d3b08882c0c5a6bd546fd5bf0a14e68b3357 (patch)
tree845c5837566dafec8d5945f09115bc278175e856 /configure.ac
parent00683dad1a27a49e99f4a28e3924e1c97b1b9594 (diff)
downloadpostgresql-setup-8c49d3b08882c0c5a6bd546fd5bf0a14e68b3357.tar.gz
postgresql-setup-8c49d3b08882c0c5a6bd546fd5bf0a14e68b3357.tar.xz
postgresql-setup-8c49d3b08882c0c5a6bd546fd5bf0a14e68b3357.zip
Generate postgresql.service and configuration file
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 1a013ab..6acd497 100644
--- a/configure.ac
+++ b/configure.ac
@@ -120,8 +120,12 @@ test -z "$INITDB_LOG" &&
test -z "$UPGRADE_LOG" &&
UPGRADE_LOG=/var/lib/pgsql/pgupgrade.log
-if test -z "$SYSCONFIG_DIR" -a "$distro_family" = redhat; then
- SYSCONFIG_DIR=/etc/sysconfig
+if test -z "$PKGCONFIG_DIR" -a "$distro_family" = redhat; then
+ PKGCONFIG_DIR=/etc/postgresql
+fi
+
+if test -z "$PGDATADIR" -a "$distro_family" = redhat; then
+ PGDATADIR=/var/lib/pgsql/data
fi
# Deal with previous versions
@@ -133,6 +137,7 @@ subst_required_var([PREVPGENGINE], [directory where old PG server resides])
subst_required_var([README_DIST], [README file for distribution])
subst_required_var([INITDB_LOG], [log file for initdb])
subst_required_var([UPGRADE_LOG], [log file for pg_upgrade])
-subst_required_var([SYSCONFIG_DIR], [log file for pg_upgrade])
+subst_required_var([PKGCONFIG_DIR], [where configuration should be stored])
+subst_required_var([PGDATADIR], [full path to postgres data dir])
AC_OUTPUT