summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPavel Raiskup <praiskup@redhat.com>2015-03-21 22:46:53 +0100
committerPavel Raiskup <praiskup@redhat.com>2015-03-22 10:10:09 +0100
commit2ebc3bed7cdda15c45a948c2c9a7d4ab23b56d4e (patch)
tree1713f26d5496e301dd9cc0752718794e87cbe9a6 /configure.ac
parentd529834d22549b48c54546d1fa463b93a0859025 (diff)
downloadpostgresql-setup-2ebc3bed7cdda15c45a948c2c9a7d4ab23b56d4e.tar.gz
postgresql-setup-2ebc3bed7cdda15c45a948c2c9a7d4ab23b56d4e.tar.xz
postgresql-setup-2ebc3bed7cdda15c45a948c2c9a7d4ab23b56d4e.zip
initscript: don't block system start-up by default
This commit should resolve complaints against pg_ctl -w usage from initscript (see rhbz#800534 for more info). The problem is that pg_ctl -w can block whole system startup too long - until the server is fully ready to accept connections. The commit 8c7b2cd5f6d9efb59568382cd8b6e88d9be517bb thus invented basically bad approach for initscript. Now, the "-w" option is used only if the PGSTARTWAIT is explicitly set to 1 by administrator. In this case, the PGSTARTTIMEOUT numeric value (in seconds) is respected (or limit 30 seconds is set by default). Otherwise, if PGSTARTWAIT is unset (default), initscript keeps checking only for the pidfile existence (at most PGSTARTTIMEOUT seconds). The hardwired 'sleep 2' command (activated before 8c7b2cd5f6 commit) is still not used - regular/default system startup should be a bit faster than before. * postgresql.init.in (start): Fix handling of PGDATA, PGPORT, PGOPTS and PGSCLS - to respect special quoting characters inside, we should escape the strings before passing those to command evaluation. Use printf %q as we use bash and we don't care too much about portability. Also, don't call postgresql-ctl with -w option if PGSTARTWAIT is empty or undefined. Implement pidfile polling for the cases PGSTARTWAIT is unset. Return success faster if server is already running. ($PGSTARTWAIT): New env variable. * postgresql-ctl.in: Don't parse $PGPORT into -o option as it is not needed. Unset PGPORT if the variable is empty - postgres server would fail with empty value. * configure.ac: Bump version to 3.3. * NEWS: Document bugfixes.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7e7ae38..95368e5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
# Use the MAJ.MIN[~SUFF]. Note that X.X > X.X~SUFF!
-AC_INIT([postgresql-setup], [3.2], [praiskup@redhat.com])
+AC_INIT([postgresql-setup], [3.3], [praiskup@redhat.com])
AC_CONFIG_AUX_DIR(auxdir)
config_aux_dir=auxdir
AC_SUBST([config_aux_dir])