summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPavel Raiskup <praiskup@redhat.com>2015-02-26 14:03:22 +0100
committerPavel Raiskup <praiskup@redhat.com>2015-02-26 16:52:25 +0100
commitf7f516372e2218daf18a79241d1fd271faa237cc (patch)
tree9f9653936f765241e606ed61b1c9eb1bb1720df3 /Makefile.am
parent1f35a8e32e9287d84b0d46f48a94eca85b59836f (diff)
downloadpostgresql-setup-f7f516372e2218daf18a79241d1fd271faa237cc.tar.gz
postgresql-setup-f7f516372e2218daf18a79241d1fd271faa237cc.tar.xz
postgresql-setup-f7f516372e2218daf18a79241d1fd271faa237cc.zip
configuration: define upgrade-config directory
Currently under /etc/postgresql-setup/upgrade. All '*.conf' files are going to be loaded run-time by postgresql-setup. * postgresql-setup.in (read_config_file): New helper to safely read configuration files. (set_var): Remove comment. (parse_upgrade_setup): Use new read_config_file(). (parse_configuration): Rename to service_configuration(). * Makefile.am: Don't include share/Makefile.inc. Indent fixes. Add install-data-hook helper to install config directory. * build-helpers/Makefile.inc: Removed. * build-helpers/build-config: Likewise. * upgrade_config.template: Removed. * etc/postgresql-setup/upgrade/postgresql.conf: New template. * configure.ac: Remove --with-upgrade-config. Package maintainers are supposed to provide those for now. * share/postgresql-setup/Makefile.inc: Removed.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am26
1 files changed, 14 insertions, 12 deletions
diff --git a/Makefile.am b/Makefile.am
index 6dad8c7..b575702 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -18,8 +18,10 @@ initscript = $(NAME_SERVICE)
initscript_in = postgresql.init.in
EXTRA_DIST =
+GENERATED_FILES =
+CLEANFILES =
-include $(srcdir)/build-helpers/Makefile.inc
+# include $(srcdir)/build-helpers/Makefile.inc
SUBDIRS = . doc tests
@@ -77,19 +79,18 @@ $(README_DIST_BASENAME): $(README_DIST_BASENAME).in $(c_s)
EXTRA_DIST += \
$(srcdir)/*.in \
- upgrade_config.template
+ $(srcdir)/etc/postgresql-setup/upgrade/postgresql.conf
-GENERATED_FILES = $(bin_SCRIPTS) \
- $(libexec_SCRIPTS) \
- $(doc_DATA) \
- $(pkgsysconf_DATA) \
- $(systemdunits_DATA) \
- $(initscripts_DATA) \
- $(systemdlegacyscripts_SCRIPTS)
+GENERATED_FILES += \
+ $(bin_SCRIPTS) \
+ $(libexec_SCRIPTS) \
+ $(doc_DATA) \
+ $(pkgsysconf_DATA) \
+ $(systemdunits_DATA) \
+ $(initscripts_DATA) \
+ $(systemdlegacyscripts_SCRIPTS)
-CLEANFILES = $(GENERATED_FILES) $(TEST_GEN_FILES_LIST)
-
-include $(srcdir)/share/postgresql-setup/Makefile.inc
+CLEANFILES += $(GENERATED_FILES) $(TEST_GEN_FILES_LIST)
$(TEST_GEN_FILES_LIST): $(GENERATED_FILES)
$(AM_V_GEN)rm -rf $(TEST_GEN_FILES_LIST) && \
@@ -99,6 +100,7 @@ $(TEST_GEN_FILES_LIST): $(GENERATED_FILES)
install-data-hook:
test `id -u` -ne 0 || systemctl daemon-reload
+ $(MKDIR_P) $(DESTDIR)/$(sysconfdir)/$(NAME_BINARYBASE)-setup/upgrade
GL_GEN_BIN = gitlog-to-changelog
GL_GEN = if test -d .git; then \