summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPavel Raiskup <praiskup@redhat.com>2015-01-07 10:25:33 +0100
committerPavel Raiskup <praiskup@redhat.com>2015-01-07 10:25:33 +0100
commitd41f894e0fc26ac48032c1f48e3f6bb354e79de1 (patch)
tree6f51376aa1966d936b58354f1b9dbbd4bdb66126 /Makefile.am
parent6ec0a16928e45a91538dc7f11b3d0198137a71f1 (diff)
downloadpostgresql-setup-d41f894e0fc26ac48032c1f48e3f6bb354e79de1.tar.gz
postgresql-setup-d41f894e0fc26ac48032c1f48e3f6bb354e79de1.tar.xz
postgresql-setup-d41f894e0fc26ac48032c1f48e3f6bb354e79de1.zip
configury: don't build ChangeLog outside git
* Makefile.am (GL_GEN): Test the .git exists and exit if not.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am22
1 files changed, 12 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index 32617a5..e40a0cc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -82,16 +82,18 @@ install-data-hook:
test `id -u` -ne 0 || systemctl daemon-reload
GL_GEN_BIN = gitlog-to-changelog
-GL_GEN = $(SHELL) $(top_srcdir)/$(config_aux_dir)/missing --run \
- $(GL_GEN_BIN) --format='%s%n%n%b%n' --since 2013-01-01 > ChangeLog ; \
- rc=$$? ; \
- if test $$rc -eq 127; then \
- if test x"$$IGNORE_CHANGELOG" != xyes; then \
- echo >&2 "ERROR: Get the $(GL_GEN_BIN) or ignore ChangeLog by IGNORE_CHANGELOG=yes" ; \
- exit 1 ; \
- fi ; \
- else \
- test $$rc -eq 0 ; \
+GL_GEN = if test -d .git; then \
+ $(SHELL) $(top_srcdir)/$(config_aux_dir)/missing --run \
+ $(GL_GEN_BIN) --format='%s%n%n%b%n' --since 2013-01-01 > ChangeLog ; \
+ rc=$$? ; \
+ if test $$rc -eq 127; then \
+ if test x"$$IGNORE_CHANGELOG" != xyes; then \
+ echo >&2 "ERROR: Get the $(GL_GEN_BIN) or ignore ChangeLog by IGNORE_CHANGELOG=yes" ; \
+ exit 1 ; \
+ fi ; \
+ else \
+ test $$rc -eq 0 ; \
+ fi \
fi
.PHONY: ChangeLog