summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPavel Raiskup <praiskup@redhat.com>2014-11-14 00:17:37 +0100
committerPavel Raiskup <praiskup@redhat.com>2014-11-14 00:17:37 +0100
commit4981646cd5649b1b70e30597ee803646d26c692e (patch)
tree0f669ffe90e93cfc71a0f1fd2fc9ffdfc76adcce /Makefile.am
parentdb3542a2f514c543c1c277f081d601817a13576f (diff)
downloadpostgresql-setup-4981646cd5649b1b70e30597ee803646d26c692e.tar.gz
postgresql-setup-4981646cd5649b1b70e30597ee803646d26c692e.tar.xz
postgresql-setup-4981646cd5649b1b70e30597ee803646d26c692e.zip
sysvinit: install init script without '.init' suffix
* Makefile.am: Make the target postgresql, not postgresql.init.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index e944382..7dd673e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -11,7 +11,7 @@ userunitsdir = /etc/systemd/system
if WANT_SYSVINIT
initscriptsdir = $(sysconfdir)/init.d
-nodist_initscripts_DATA = postgresql$(DISTSUFF).init
+nodist_initscripts_DATA = postgresql$(DISTSUFF)
else
systemdunitsdir = $(prefix)/lib/systemd/system
nodist_systemdunits_DATA = postgresql$(DISTSUFF).service postgresql$(DISTSUFF)@.service
@@ -30,7 +30,7 @@ postgresql$(DISTSUFF)-setup: postgresql-setup.in $(c_s)
postgresql$(DISTSUFF)-check-db-dir: postgresql-check-db-dir.in $(c_s)
$(INSTANTIATE_SCRIPT)
-postgresql$(DISTSUFF).init: postgresql.init.in $(c_s)
+postgresql$(DISTSUFF): postgresql.init.in $(c_s)
$(INSTANTIATE)
# In ideal world, postgresql@.service would be hardlink to postgresql.service.