summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPavel Raiskup <praiskup@redhat.com>2015-03-02 14:44:39 +0100
committerPavel Raiskup <praiskup@redhat.com>2015-03-02 14:48:54 +0100
commit1b17292099daea774c2b335a85f8afebf7c99569 (patch)
tree3428f1458518f857e680aa942e734201ca36fdcf /Makefile.am
parent4dcf043cc8d1b4d99c64418958329c5f882f4034 (diff)
downloadpostgresql-setup-1b17292099daea774c2b335a85f8afebf7c99569.tar.gz
postgresql-setup-1b17292099daea774c2b335a85f8afebf7c99569.tar.xz
postgresql-setup-1b17292099daea774c2b335a85f8afebf7c99569.zip
configury: better handle paths
.. to avoid FTBFS with SCLs. Use pgdocdir rather then docdir because the 'docdir' is not set by %configure by default. * Makefile.am (pkgname): Drop, not needed. (pgdoc_DATA): Use this rather than doc_DATA. * configure.ac: Fix pgdocdir. (PGDATADIR): Define as subdirectory of localstatedir.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 2 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 6371bb7..3f64a38 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,3 @@
-pkgname = $(NAME_PACKAGE)
-
setup = $(NAME_BINARYBASE)-setup
setup_in = postgresql-setup.in
@@ -38,7 +36,7 @@ systemdunits_DATA = $(service) $(serviceat)
legacyscripts_SCRIPTS = initdb upgrade
endif
-doc_DATA = $(README_DIST_BASENAME)
+pgdoc_DATA = $(README_DIST_BASENAME)
noinst_DATA = $(TEST_GEN_FILES_LIST)
@@ -83,7 +81,7 @@ include $(srcdir)/share/postgresql-setup/Makefile.inc
GENERATED_FILES += \
$(bin_SCRIPTS) \
$(libexec_SCRIPTS) \
- $(doc_DATA) \
+ $(pgdoc_DATA) \
$(pkgsysconf_DATA) \
$(systemdunits_DATA) \
$(initscripts_DATA) \