summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPavel Raiskup <praiskup@redhat.com>2014-09-16 10:39:40 +0200
committerPavel Raiskup <praiskup@redhat.com>2014-09-16 13:46:48 +0200
commit112c8af118dfa21b79b4f86e286c3f0bf510884a (patch)
tree40eea86126ff3fe2efa6aa87f20fc82de371dc02 /Makefile.am
parent9f51b237a5cda60597e0fb43de24612223cc60d6 (diff)
downloadpostgresql-setup-112c8af118dfa21b79b4f86e286c3f0bf510884a.tar.gz
postgresql-setup-112c8af118dfa21b79b4f86e286c3f0bf510884a.tar.xz
postgresql-setup-112c8af118dfa21b79b4f86e286c3f0bf510884a.zip
README.rpmd-dist: template fixing
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 809980f..23f6a6f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,3 +1,5 @@
+pkgname = postgresql$(DISTSUFF)
+
SUBDIRS = . doc
bin_SCRIPTS = postgresql$(DISTSUFF)-setup
@@ -19,13 +21,18 @@ nodist_pgdoc_DATA = README.rpm-dist
# directly, e.g. libexecdir may result into '${exec_prefix}/libexec' -- but we
# need fully expanded strings there.
SED_RULES = \
+ -e 's|@__FILE__[@]|$@|g' \
+ -e 's|@bindir[@]|$(bindir)|g' \
-e 's|@DISTSUFF[@]|$(DISTSUFF)|g' \
+ -e 's|@docdir[@]|$(docdir)|g' \
-e 's|@libdir[@]|$(libdir)|g' \
-e 's|@libexecdir[@]|$(libexecdir)|g' \
-e 's|@PG_CTL_BIN[@]|$(PG_CTL_BIN)|g' \
-e 's|@PGDATADIR[@]|$(PGDATADIR)|g' \
+ -e 's|@pgcontribdocdir[@]|$(pgcontribdocdir)|g' \
-e 's|@pgdocdir[@]|$(pgdocdir)|g' \
-e 's|@PGENGINE[@]|$(PGENGINE)|g' \
+ -e 's|@pkgname[@]|$(pkgname)|g' \
-e 's|@PGMAJORVERSION[@]|$(PGMAJORVERSION)|g' \
-e 's|@PGVERSION[@]|$(PGVERSION)|g' \
-e 's|@PKGCONFIG_DIR[@]|$(PKGCONFIG_DIR)|g' \
@@ -35,8 +42,7 @@ SED_RULES = \
-e 's|@README_DIST[@]|$(README_DIST)|g' \
-e 's|@SU[@]|$(SU)|g' \
-e 's|@systemdunitsdir[@]|$(systemdunitsdir)|' \
- -e 's|@VERSION[@]|$(VERSION)|g' \
- -e 's|@__FILE__[@]|$@|g'
+ -e 's|@VERSION[@]|$(VERSION)|g'
SED_CALL = $(SED) $(SED_RULES)