summaryrefslogtreecommitdiffstats
path: root/postgresql.spec
diff options
context:
space:
mode:
authorPavel Kajaba <pkajaba@redhat.com>2015-11-18 10:20:25 +0100
committerPavel Kajaba <pkajaba@redhat.com>2015-11-18 10:20:25 +0100
commit412ca9cc5958e5402ad8804e368e2c8c1381cc05 (patch)
tree185b1ed5c4bbe9c3a83508fea40ec5e09ca12749 /postgresql.spec
parentf51c859081bdb81b89293fa7a4d52782ce8429cb (diff)
downloadpostgresql-412ca9cc5958e5402ad8804e368e2c8c1381cc05.tar.gz
postgresql-412ca9cc5958e5402ad8804e368e2c8c1381cc05.tar.xz
postgresql-412ca9cc5958e5402ad8804e368e2c8c1381cc05.zip
Added rebase to 9.5
Diffstat (limited to 'postgresql.spec')
-rw-r--r--postgresql.spec64
1 files changed, 47 insertions, 17 deletions
diff --git a/postgresql.spec b/postgresql.spec
index 323c0d9..3a9d938 100644
--- a/postgresql.spec
+++ b/postgresql.spec
@@ -36,6 +36,7 @@
%{!?test:%global test 1}
%{!?upgrade:%global upgrade 1}
+%{!?rewind:%global rewind 1}
%{!?plpython:%global plpython 1}
%{!?plpython3:%global plpython3 0}
%{!?pltcl:%global pltcl 1}
@@ -60,11 +61,10 @@
%endif
%{!?_pkgdocdir: %global _pkgdocdir %{_docdir}/%{name}-%{version}}
-
Summary: PostgreSQL client programs
Name: %{?scl_prefix}postgresql
-%global majorversion 9.4
-Version: 9.4.5
+%global majorversion 9.5
+Version: 9.5
Release: 1%{?dist}
# The PostgreSQL license is very similar to other MIT licenses, but the OSI
@@ -73,11 +73,10 @@ License: PostgreSQL
Group: Applications/Databases
Url: http://www.postgresql.org/
-%global setup_version 3.3
+%global setup_version 3.5
%global service_name %{?scl_prefix}postgresql.service
-
-Source0: ftp://ftp.postgresql.org/pub/source/v%{version}/postgresql-%{version}.tar.bz2
+Source0: https://pkajaba.fedorapeople.org/postgresql-%{version}.tar.bz2
# The PDF file is generated by generate-pdf.sh, which see for comments
Source1: postgresql-%{version}-US.pdf
# generate-pdf.sh is not used during RPM build, but include for documentation
@@ -183,7 +182,6 @@ Group: Applications/Databases
Requires(post): glibc
Requires(postun): glibc
%{?scl:Requires:%scl_runtime}
-
%description libs
The postgresql-libs package provides the essential shared libraries for any
PostgreSQL client program or interface. You will need to install this package
@@ -250,7 +248,6 @@ with a PostgreSQL database management server. It also contains the ecpg
Embedded C Postgres preprocessor. You need to install this package if you want
to develop applications which will interact with a PostgreSQL server.
-
%if %upgrade
%package upgrade
Summary: Support for upgrading from the previous major release of PostgreSQL
@@ -265,6 +262,19 @@ files needed for upgrading a PostgreSQL database from the core system version
of PostgreSQL.
%endif
+%if %rewind
+%package rewind
+Summary: Support for synchronize a PostgreSQL data directory with another directory that was forked from the first one
+Group: Applications/Databases
+Requires: %{name}-server%{?_isa} = %{version}-%{release}
+Requires: %{name}-libs%{?_isa} = %{version}-%{release}
+%{?scl:Requires:%scl_runtime}
+
+%description rewind
+The postgresql-rewind package contains the pg_rewind utility and its translation.
+pg_rewind is a tool for synchronizing a PostgreSQL cluster with another copy of the same
+cluster, after the clusters' timelines have diverged.
+%endif
%if %plperl
%package plperl
@@ -734,9 +744,12 @@ rm -rf $RPM_BUILD_ROOT%{_docdir}/pgsql
rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
%if !%upgrade
rm -f $RPM_BUILD_ROOT%{_bindir}/pg_upgrade
-rm -f $RPM_BUILD_ROOT%{_libdir}/pgsql/pg_upgrade_support.so
rm -f $RPM_BUILD_ROOT%{_mandir}/man1/pg_upgrade.*
%endif
+%if !%rewind
+rm -f $RPM_BUILD_ROOT%{_bindir}/pg_rewind
+rm -f $RPM_BUILD_ROOT%{_mandir}/man1/pg_rewind.*
+%endif
# initialize file lists
cp /dev/null main.lst
@@ -769,6 +782,8 @@ cat pg_config-%{majorversion}.lang >>main.lst
cat pg_dump-%{majorversion}.lang >>main.lst
%find_lang pg_resetxlog-%{majorversion}
cat pg_resetxlog-%{majorversion}.lang >>server.lst
+%find_lang pg_rewind-%{majorversion}
+cat pg_rewind-%{majorversion}.lang >>server.lst
%find_lang pgscripts-%{majorversion}
cat pgscripts-%{majorversion}.lang >>main.lst
%if %plperl
@@ -920,12 +935,11 @@ cd -
%{_datadir}/pgsql/extension/seg*
%{_datadir}/pgsql/extension/tablefunc*
%{_datadir}/pgsql/extension/tcn*
-%{_datadir}/pgsql/extension/test_parser*
-%{_datadir}/pgsql/extension/test_shm_mq*
%{_datadir}/pgsql/extension/timetravel*
%{_datadir}/pgsql/extension/tsearch2*
+%{_datadir}/pgsql/extension/tsm_system_rows*
+%{_datadir}/pgsql/extension/tsm_system_time*
%{_datadir}/pgsql/extension/unaccent*
-%{_datadir}/pgsql/extension/worker_spi*
%{_libdir}/pgsql/adminpack.so
%{_libdir}/pgsql/auth_delay.so
%{_libdir}/pgsql/auto_explain.so
@@ -938,16 +952,24 @@ cd -
%{_libdir}/pgsql/dblink.so
%{_libdir}/pgsql/dict_int.so
%{_libdir}/pgsql/dict_xsyn.so
-%{_libdir}/pgsql/dummy_seclabel.so
%{_libdir}/pgsql/earthdistance.so
%{_libdir}/pgsql/file_fdw.so
%{_libdir}/pgsql/fuzzystrmatch.so
%{_libdir}/pgsql/hstore.so
+%if %plperl
+%{_libdir}/pgsql/hstore_plperl.so
+%endif
+%if %plpython
+%{_libdir}/pgsql/hstore_plpython2.so
+%endif
%{_libdir}/pgsql/insert_username.so
%{_libdir}/pgsql/_int.so
%{_libdir}/pgsql/isn.so
%{_libdir}/pgsql/lo.so
%{_libdir}/pgsql/ltree.so
+%if %plpython
+%{_libdir}/pgsql/ltree_plpython2.so
+%endif
%{_libdir}/pgsql/moddatetime.so
%{_libdir}/pgsql/pageinspect.so
%{_libdir}/pgsql/passwordcheck.so
@@ -964,12 +986,11 @@ cd -
%{_libdir}/pgsql/tablefunc.so
%{_libdir}/pgsql/tcn.so
%{_libdir}/pgsql/test_decoding.so
-%{_libdir}/pgsql/test_parser.so
-%{_libdir}/pgsql/test_shm_mq.so
%{_libdir}/pgsql/timetravel.so
%{_libdir}/pgsql/tsearch2.so
+%{_libdir}/pgsql/tsm_system_rows.so
+%{_libdir}/pgsql/tsm_system_time.so
%{_libdir}/pgsql/unaccent.so
-%{_libdir}/pgsql/worker_spi.so
%if %selinux
%{_datadir}/pgsql/contrib/sepgsql.sql
%{_libdir}/pgsql/sepgsql.so
@@ -1091,10 +1112,15 @@ cd -
%{_mandir}/man1/ecpg.*
%{_mandir}/man3/SPI_*
+%if %rewind
+%files rewind
+%{_bindir}/pg_rewind
+%{_mandir}/man1/pg_rewind.*
+%endif
+
%if %upgrade
%files upgrade
%{_bindir}/pg_upgrade
-%{_libdir}/pgsql/pg_upgrade_support.so
%{_mandir}/man1/pg_upgrade.*
%endif
@@ -1135,6 +1161,10 @@ cd -
%endif
%changelog
+* Wed Nov 18 2015 Pavel Kajaba <pkajaba@redhat.com> - 9.5-1
+- Rebase to 9.5. Added: pg_rewind, tsm_system_time, tsm_system_row,
+ removed: test_parser, test_shm_mq, worker_spi
+
* Wed Oct 21 2015 Pavel Raiskup <praiskup@redhat.com> - 9.4.5-1
- update to 9.4.5 per release notes
http://www.postgresql.org/docs/9.4/static/release-9-4-5.html