summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorChristopher Davis <loafier@gmail.com>2006-08-15 05:56:42 +0000
committerChristopher Davis <loafier@gmail.com>2006-08-15 05:56:42 +0000
commit31d5cc05e5d42fe36875efee92cdf3a4f203636f (patch)
treebdfc94ac91b1935ead7882fa0f463b24fc28afa1 /configure.in
parente74c84f65a3292970d45389ca01f3d64810707da (diff)
downloadirssi-python-31d5cc05e5d42fe36875efee92cdf3a4f203636f.tar.gz
irssi-python-31d5cc05e5d42fe36875efee92cdf3a4f203636f.tar.xz
irssi-python-31d5cc05e5d42fe36875efee92cdf3a4f203636f.zip
test1
git-svn-id: http://svn.irssi.org/repos/irssi-python@4317 dbcabf3a-b0e7-0310-adc4-f8d773084564
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 07821bd..0a0e885 100644
--- a/configure.in
+++ b/configure.in
@@ -41,6 +41,11 @@ if test -z $irssi_path; then
AC_MSG_ERROR([Path to Irssi distribution not specified. See --with-irssi option.])
fi
+# fix relative paths (from modules/icb)
+old=`pwd`
+irssi_path=`eval cd $irssi_path; pwd`
+cd $old
+
IRSSI_DIST=$irssi_path
AC_SUBST([IRSSI_DIST])
IRSSI_PYTHON_INCLUDES="-I${IRSSI_DIST} -I${IRSSI_DIST}/src -I${IRSSI_DIST}/src/fe-common/core \