summaryrefslogtreecommitdiffstats
path: root/gnome2-accessibility-guide/Makefile.am
diff options
context:
space:
mode:
authorBrent Smith <gnome@nextreality.net>2006-03-11 21:28:16 +0000
committerBrent Smith <bmsmith@src.gnome.org>2006-03-11 21:28:16 +0000
commite54f4e852954e92d0f3f3a4c37ebe9212041c98f (patch)
treea104b207a01c03982edca79b758b08a7b0127239 /gnome2-accessibility-guide/Makefile.am
parentb4344e6f1f61b8483e4cb307eda77f0d3a41dc13 (diff)
downloadgnome-user-docs-e54f4e852954e92d0f3f3a4c37ebe9212041c98f.tar.gz
gnome-user-docs-e54f4e852954e92d0f3f3a4c37ebe9212041c98f.tar.xz
gnome-user-docs-e54f4e852954e92d0f3f3a4c37ebe9212041c98f.zip
Install targets for PDFs (patch from Shaun McCance) PDF versions of the
2006-03-11 Brent Smith <gnome@nextreality.net> * gnome2-accessibility-guide/C/gnome-access-guide.pdf: * gnome2-accessibility-guide/Makefile.am: * gnome2-system-admin-guide/C/system-admin-guide.pdf: * gnome2-system-admin-guide/Makefile.am: * gnome2-user-guide/C/user-guide.pdf: * gnome2-user-guide/Makefile.am: Install targets for PDFs (patch from Shaun McCance) PDF versions of the documentation (to be updated right before release)
Diffstat (limited to 'gnome2-accessibility-guide/Makefile.am')
-rw-r--r--gnome2-accessibility-guide/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/gnome2-accessibility-guide/Makefile.am b/gnome2-accessibility-guide/Makefile.am
index 5625619..2b43419 100644
--- a/gnome2-accessibility-guide/Makefile.am
+++ b/gnome2-accessibility-guide/Makefile.am
@@ -13,3 +13,14 @@ DOC_ENTITIES = \
legal.xml
DOC_LINGUAS = it
+
+install: install-doc-pdf
+install-doc-pdf:
+ for lc in C $(DOC_LINGUAS); do \
+ pdf="$$lc/$(DOC_MODULE).pdf"; \
+ if [ -f "$$pdf" ]; then spdf="$$pdf"; else spdf="$(srcdir)/$$pdf"; fi; \
+ if [ -f "$$spdf" ]; then \
+ $(mkinstalldirs) "$(DESTDIR)$(HELP_DIR)/$(DOC_MODULE)/$$lc"; \
+ $(INSTALL_DATA) "$$spdf" "$(DESTDIR)$(HELP_DIR)/$(DOC_MODULE)/$$pdf"; \
+ fi; \
+ done