summaryrefslogtreecommitdiffstats
path: root/src/man/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2012-01-29 22:11:45 +0100
committerStephen Gallagher <sgallagh@redhat.com>2012-01-30 21:47:53 -0500
commit4182b3a1f9f6e1823db9832533c6c9e51d13da8e (patch)
tree91f0d125db52071880f9e50a8b83603003f86ef3 /src/man/Makefile.am
parent173f557c915aeee80a0c3dc8ae4d3f44dd5bc7c9 (diff)
downloadsssd_unused-4182b3a1f9f6e1823db9832533c6c9e51d13da8e.tar.gz
sssd_unused-4182b3a1f9f6e1823db9832533c6c9e51d13da8e.tar.xz
sssd_unused-4182b3a1f9f6e1823db9832533c6c9e51d13da8e.zip
Include sudo manual pages only conditionally
Diffstat (limited to 'src/man/Makefile.am')
-rw-r--r--src/man/Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/src/man/Makefile.am b/src/man/Makefile.am
index 09af8985..36c3921d 100644
--- a/src/man/Makefile.am
+++ b/src/man/Makefile.am
@@ -5,11 +5,20 @@ top_builddir = ../..
# MANPAGES #
############
+
+# If no conditions are given, *all* conditionals are expanded. We don't
+# to include any conditions by default, so we need to pass a phony conditional
+CONDS=with_false
+if BUILD_SUDO
+# conditionals are delimeted with a semicolon
+CONDS+=;with_sudo
+endif
+
#Special Rules:
export SGML_CATALOG_FILES
-DOCBOOK_XSLT = http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl
+DOCBOOK_XSLT = http://docbook.sourceforge.net/release/xsl/current/manpages/profile-docbook.xsl
XMLLINT_FLAGS = --catalogs --postvalid --nonet --xinclude --noout
-XSLTPROC_FLAGS = --catalogs --xinclude --nonet
+XSLTPROC_FLAGS = --stringparam profile.condition "$(CONDS)" --catalogs --xinclude --nonet
man_MANS = \
sss_useradd.8 sss_userdel.8 sss_usermod.8 \