summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Disseldorp <ddiss@samba.org>2016-02-24 17:18:00 +0100
committerLukas Slebodnik <lslebodn@redhat.com>2016-02-24 17:52:46 +0100
commitfaa16fc9f0c9a02b26497e7cf148a92586144c08 (patch)
tree240bdc8ae2a65ac14062427bb7329165eac9959e /configure.ac
parentc32266e79f9d4bebd0c31eaa8d6fa26050e7fb3e (diff)
downloadsssd-faa16fc9f0c9a02b26497e7cf148a92586144c08.tar.gz
sssd-faa16fc9f0c9a02b26497e7cf148a92586144c08.tar.xz
sssd-faa16fc9f0c9a02b26497e7cf148a92586144c08.zip
build: detect endianness at configure time
WORDS_BIGENDIAN, HAVE_BIG_ENDIAN and HAVE_LITTLE_ENDIAN are needed by Samba. See Samba's byteorder.h header for an example. Signed-off-by: David Disseldorp <ddiss@samba.org> Reviewed-by: Lukáš Slebodník <lslebodn@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9f099276e..9b674ba02 100644
--- a/configure.ac
+++ b/configure.ac
@@ -76,6 +76,9 @@ AC_CHECK_FUNCS([ utimensat \
#Check for endian headers
AC_CHECK_HEADERS([endian.h sys/endian.h byteswap.h])
+AC_C_BIGENDIAN([AC_DEFINE(HAVE_BIG_ENDIAN, [1], [whether platform is big endian])],
+ [AC_DEFINE(HAVE_LITTLE_ENDIAN, [1], [whether platform is little endian])])
+
#Set the NSS library install path
AC_ARG_ENABLE([nsslibdir], [AS_HELP_STRING([--enable-nsslibdir],
[Where to install nss libraries ($libdir)])],