summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLukas Slebodnik <lslebodn@redhat.com>2017-01-25 16:12:02 +0100
committerLukas Slebodnik <lslebodn@redhat.com>2017-01-26 14:09:40 +0100
commitc369b062182c746849196e495db467198039edf4 (patch)
tree2074ec8bd4328d2d780a13747ec8d31f640555e0 /Makefile.am
parent33da7b13eaed678789b7ccba00e49065a8838e9a (diff)
downloadsssd-c369b062182c746849196e495db467198039edf4.tar.gz
sssd-c369b062182c746849196e495db467198039edf4.tar.xz
sssd-c369b062182c746849196e495db467198039edf4.zip
BUILD: Fix linking of test_wbc_calls
Client code does not anymore depend on libpthread in master. This is a reason why we didn't notice any linking failure in master. But the test should be linked with CLIENT_LIBS. CCLD test_wbc_calls /usr/bin/ld: src/sss_client/test_wbc_calls-common.o: undefined reference to symbol 'pthread_mutexattr_setrobust@@GLIBC_2.12' //lib/x86_64-linux-gnu/libpthread.so.0: error adding symbols: DSO missing from command line collect2: error: ld returned 1 exit status Makefile:12460: recipe for target 'test_wbc_calls' failed Reviewed-by: Fabiano FidĂȘncio <fidencio@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 661e9447d..674d328f5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2703,6 +2703,7 @@ test_wbc_calls_LDFLAGS = \
-Wl,-wrap,sss_nss_getnamebysid \
$(NULL)
test_wbc_calls_LDADD = \
+ $(CLIENT_LIBS) \
$(CMOCKA_LIBS) \
$(POPT_LIBS) \
$(TALLOC_LIBS) \