summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2017-03-07 13:49:21 +0100
committerJakub Hrozek <jhrozek@redhat.com>2017-03-27 09:57:31 +0200
commitbea0dc79faf609de8603cb42f190adae544bc8fb (patch)
tree34ebc4a1653e1e6bb211384e7f044d7b4c426d77 /Makefile.am
parent9dcdbf596e138df3eec202487549a67cd3b0091b (diff)
downloadsssd-bea0dc79faf609de8603cb42f190adae544bc8fb.tar.gz
sssd-bea0dc79faf609de8603cb42f190adae544bc8fb.tar.xz
sssd-bea0dc79faf609de8603cb42f190adae544bc8fb.zip
KCM: Implement an internal ccache storage and retrieval API
In order for the KCM server to work with ccaches stored in different locations, implement a middle-man between the KCM server and the ccache storage. This module has asynchronous API because we can't assume anything about where the ccaches are stored. Reviewed-by: Michal Židek <mzidek@redhat.com> Reviewed-by: Simo Sorce <simo@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 4248536e9..a2b9dc49e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -711,6 +711,9 @@ dist_noinst_HEADERS = \
src/responder/secrets/secsrv_proxy.h \
src/responder/kcm/kcm.h \
src/responder/kcm/kcmsrv_pvt.h \
+ src/responder/kcm/kcmsrv_ccache.h \
+ src/responder/kcm/kcmsrv_ccache_pvt.h \
+ src/responder/kcm/kcmsrv_ccache_be.h \
src/sbus/sbus_client.h \
src/sbus/sssd_dbus.h \
src/sbus/sssd_dbus_meta.h \
@@ -1488,16 +1491,22 @@ if BUILD_KCM
sssd_kcm_SOURCES = \
src/responder/kcm/kcm.c \
src/responder/kcm/kcmsrv_cmd.c \
+ src/responder/kcm/kcmsrv_ccache.c \
src/util/sss_sockets.c \
+ src/util/sss_krb5.c \
+ src/util/sss_iobuf.c \
$(SSSD_RESPONDER_OBJ) \
$(NULL)
sssd_kcm_CFLAGS = \
$(AM_CFLAGS) \
$(KRB5_CFLAGS) \
+ $(UUID_CFLAGS) \
$(NULL)
sssd_kcm_LDADD = \
$(KRB5_LIBS) \
$(SSSD_LIBS) \
+ $(UUID_LIBS) \
+ $(SYSTEMD_DAEMON_LIBS) \
$(SSSD_INTERNAL_LTLIBS) \
$(NULL)
endif