summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPavel Březina <pbrezina@redhat.com>2015-11-06 13:00:47 +0100
committerLukas Slebodnik <lslebodn@redhat.com>2015-12-15 16:25:57 +0100
commita13cf3d295a4a6654dfa7e4193c0a2bc8bb78e92 (patch)
treed3cd4769dd68a4adb976ab9744f4f83b5f7b0e1d /Makefile.am
parente131fef2d3f40bce5af85613690df8aa15f90fde (diff)
downloadsssd-a13cf3d295a4a6654dfa7e4193c0a2bc8bb78e92.tar.gz
sssd-a13cf3d295a4a6654dfa7e4193c0a2bc8bb78e92.tar.xz
sssd-a13cf3d295a4a6654dfa7e4193c0a2bc8bb78e92.zip
SUDO: convert periodical refreshes to be_ptask
This removes old sudo timer and simplyfies code a lot. It also allows to manage offline/online state. - Full and smart refresh are disabled when offline. - Full refresh is run immediately when sssd is back online. - Smart refresh is scheduled normally when sssd is back online. Resolves: https://fedorahosted.org/sssd/ticket/1943 Reviewed-by: Jakub Hrozek <jhrozek@redhat.com> Reviewed-by: Lukáš Slebodník <lslebodn@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 9f76dd60b..a9d3f25d3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2856,8 +2856,8 @@ if BUILD_SUDO
libsss_ldap_common_la_SOURCES += \
src/providers/ldap/sdap_sudo_cache.c \
src/providers/ldap/sdap_async_sudo.c \
- src/providers/ldap/sdap_async_sudo_timer.c \
src/providers/ldap/sdap_async_sudo_hostinfo.c \
+ src/providers/ldap/sdap_sudo_refresh.c \
src/providers/ldap/sdap_sudo.c
endif