summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJakub Hrozek <jhrozek@redhat.com>2017-01-13 09:31:03 +0100
committerLukas Slebodnik <lslebodn@redhat.com>2017-03-14 13:31:47 +0100
commit91b0592cdab22915dff27ceae6d8e49c608aea4a (patch)
tree0dbfa2bb14a1c1a0fb23f38318ea103126d5cbe2 /Makefile.am
parentca90f2102a43a3d49a2ef26610d7b4ff3062a823 (diff)
downloadsssd-91b0592cdab22915dff27ceae6d8e49c608aea4a.tar.gz
sssd-91b0592cdab22915dff27ceae6d8e49c608aea4a.tar.xz
sssd-91b0592cdab22915dff27ceae6d8e49c608aea4a.zip
TESTS: test the curl wrapper with a command-line tool
In order to test the curl integration code, this patch adds a command-line tool and tests that it's possible to drive a conversation with the secrets responder using the tool. Reviewed-by: Pavel Březina <pbrezina@redhat.com> Reviewed-by: Lukáš Slebodník <lslebodn@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 869ac2228..45b04de26 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3248,6 +3248,9 @@ endif
if BUILD_AUTOFS
noinst_PROGRAMS += autofs_test_client
endif
+if BUILD_WITH_LIBCURL
+noinst_PROGRAMS += tcurl-test-tool
+endif
pam_test_client_SOURCES = src/sss_client/pam_test_client.c
pam_test_client_LDADD = $(PAM_LIBS) $(PAM_MISC_LIBS)
@@ -3261,6 +3264,23 @@ autofs_test_client_CFLAGS = $(AM_CFLAGS)
autofs_test_client_LDADD = -lpopt $(CLIENT_LIBS)
endif
+if BUILD_WITH_LIBCURL
+tcurl_test_tool_SOURCES = \
+ src/tests/tcurl_test_tool.c \
+ src/util/tev_curl.c \
+ src/util/sss_iobuf.c \
+ $(NULL)
+tcurl_test_tool_CFLAGS = \
+ $(AM_CFLAGS) \
+ $(CURL_CFLAGS) \
+ $(NULL)
+tcurl_test_tool_LDADD = \
+ $(CURL_LIBS) \
+ $(SSSD_LIBS) \
+ $(SSSD_INTERNAL_LTLIBS) \
+ $(NULL)
+endif
+
#####################
# Integration tests #
#####################