summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorPavel Březina <pbrezina@redhat.com>2017-03-10 10:44:57 +0100
committerJakub Hrozek <jhrozek@redhat.com>2017-03-14 12:34:53 +0100
commit7cd226414c7bcdd32f05416df64ebda3ac869bd7 (patch)
tree58237af9f4bab2b763b6f5ff47e398d1e9f1d4eb /Makefile.am
parent828fe7528fbe6971701d16aed87ba12dd91da55f (diff)
downloadsssd-7cd226414c7bcdd32f05416df64ebda3ac869bd7.tar.gz
sssd-7cd226414c7bcdd32f05416df64ebda3ac869bd7.tar.xz
sssd-7cd226414c7bcdd32f05416df64ebda3ac869bd7.zip
CACHE_REQ: Move result manipulation into a separate module
This patch is preparing the field for coming up patches where new lookup logic will be added. Taking this into consideration let's move the result manipulation code into a separate module and focus purely in the lookups logic in the main module. Related: https://pagure.io/sssd/sssd/issue/3001 Reviewed-by: Fabiano Fidêncio <fidencio@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 34da1f002..46ed3311a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -505,6 +505,7 @@ EXTRA_DIST =
SSSD_CACHE_REQ_OBJ = \
src/responder/common/cache_req/cache_req.c \
+ src/responder/common/cache_req/cache_req_result.c \
src/responder/common/cache_req/cache_req_search.c \
src/responder/common/cache_req/cache_req_data.c \
src/responder/common/cache_req/plugins/cache_req_common.c \