summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMichal Židek <mzidek@redhat.com>2017-02-08 12:01:37 +0100
committerLukas Slebodnik <lslebodn@redhat.com>2017-04-06 13:41:33 +0200
commit78a08d30b5fbf6e1e3b589e0cf67022e0c1faa33 (patch)
tree11a8c1bec79b40cf02c03044640c73e98b3849dd /Makefile.am
parentb07bcd8b99590bd404733fa7ff1add37c55126bc (diff)
downloadsssd-78a08d30b5fbf6e1e3b589e0cf67022e0c1faa33.tar.gz
sssd-78a08d30b5fbf6e1e3b589e0cf67022e0c1faa33.tar.xz
sssd-78a08d30b5fbf6e1e3b589e0cf67022e0c1faa33.zip
selinux: Do not fail if SELinux is not managed
Previously we failed if semanage_is_managed returned 0 or -1 (not managed or error). With this patch we only fail in case of error and continue normally if selinux is not managed by libsemanage at all. Resolves: https://fedorahosted.org/sssd/ticket/3297 Reviewed-by: Lukáš Slebodník <lslebodn@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 5264183cd..d45c0ff75 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4040,6 +4040,7 @@ selinux_child_SOURCES = \
src/util/atomic_io.c \
src/util/util.c \
src/util/util_ext.c \
+ src/util/util_errors.c
$(NULL)
selinux_child_CFLAGS = \
$(AM_CFLAGS) \