summaryrefslogtreecommitdiffstats
path: root/src/service-dbus/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/service-dbus/CMakeLists.txt')
-rw-r--r--src/service-dbus/CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/src/service-dbus/CMakeLists.txt b/src/service-dbus/CMakeLists.txt
index 3cc2082..4ba3231 100644
--- a/src/service-dbus/CMakeLists.txt
+++ b/src/service-dbus/CMakeLists.txt
@@ -23,8 +23,15 @@ add_library(${LIBRARY_NAME} SHARED
# Require libgio
pkg_check_modules(GIO REQUIRED gio-2.0)
-include_directories(${CMAKE_CURRENT_BINARY_DIR} ${CMPI_INCLUDE_DIR} ${GIO_INCLUDE_DIRS})
-target_link_libraries(${LIBRARY_NAME} openlmicommon ${KONKRETCMPI_LIBRARIES} ${GIO_LIBRARIES})
+include_directories(${CMAKE_CURRENT_BINARY_DIR}
+ ${CMPI_INCLUDE_DIR}
+ ${GIO_INCLUDE_DIRS}
+ ${CMAKE_SOURCE_DIR}/src/indmanager)
+target_link_libraries(${LIBRARY_NAME}
+ openlmicommon
+ openlmiindmanager
+ ${KONKRETCMPI_LIBRARIES}
+ ${GIO_LIBRARIES})
# Create registration file
cim_registration(${PROVIDER_NAME} ${LIBRARY_NAME} ${MOF} share/openlmi-providers)