summaryrefslogtreecommitdiffstats
path: root/src/power/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/power/CMakeLists.txt')
-rw-r--r--src/power/CMakeLists.txt12
1 files changed, 0 insertions, 12 deletions
diff --git a/src/power/CMakeLists.txt b/src/power/CMakeLists.txt
index 72087b7..c6bfdad 100644
--- a/src/power/CMakeLists.txt
+++ b/src/power/CMakeLists.txt
@@ -1,16 +1,4 @@
-cmake_minimum_required (VERSION 2.6)
-
-set(CMAKE_C_FLAGS "-std=c99 -Wall -pedantic -g")
-
-add_subdirectory(src)
-
-if(CMAKE_SIZEOF_VOID_P EQUAL 4)
- set(LIB_SUFFIX "")
-else(CMAKE_SIZEOF_VOID_P EQUAL 4)
- SET(LIB_SUFFIX 64)
-endif(CMAKE_SIZEOF_VOID_P EQUAL 4)
-
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/src/Linux_PowerManagement.registration DESTINATION share/sblim-cmpi-power/)
install(FILES Linux_PowerManagement.mof DESTINATION share/sblim-cmpi-power/)
install(FILES provider-register.sh DESTINATION share/sblim-cmpi-power/)