summaryrefslogtreecommitdiffstats
path: root/src/journald/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/journald/CMakeLists.txt')
-rw-r--r--src/journald/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/journald/CMakeLists.txt b/src/journald/CMakeLists.txt
index 7e956c0..63a5246 100644
--- a/src/journald/CMakeLists.txt
+++ b/src/journald/CMakeLists.txt
@@ -52,7 +52,7 @@ set(TARGET_MOF "${CMAKE_BINARY_DIR}/mof/90_LMI_Journald_Profile.mof")
profile_mof_generate("90_LMI_Journald_Profile.mof.skel" "${TARGET_MOF}" "${CIM_PROVIDERS_CLASSES}")
# Create registration file
-cim_registration(${PROVIDER_NAME} ${LIBRARY_NAME} ${MOF} share/openlmi-providers)
+cim_registration(${PROVIDER_NAME} ${LIBRARY_NAME} ${MOF} share/openlmi-providers "${TARGET_MOF}")
install(TARGETS ${LIBRARY_NAME} DESTINATION lib${LIB_SUFFIX}/cmpi/)
install(PROGRAMS ${CIMPROVAGT_SCRIPT} DESTINATION libexec/pegasus)